Is ezdata working or not?



  • Hi.
    Right now the service https://ezdata.m5stack.com:8088/debugger/ is not working.
    Nor is woring to send data to ezdata from my projects.

    Nor is working the site https://ezdata.m5stack.com is working, which gives this answer:

    0_1640475509078_Screenshot 2021-12-26 at 0.37.42.png

    Is the service down? should we move to other?



  • Update.
    When using ezdata "Save value" box, the M5go gets the error "Exception: Invalid Request in the setData ezdata function.


  • M5Stack

    the first question is fixed. you could clean the browser cache and refresh the page it would be solved.

    the invalid request question could use a try except to cover the request code. and then when the error happened. it won't stuck the program.

    0_1640589255398_88e4287c-8c0a-487a-aa37-e2fd806ce45b-image.png



  • @m5stack on my core2 after 2 set.data commands I get the [Errno 12] ENOMEM every time
    makes the EZ data function useless.
    Ive tried slowing down set data commands , once every 30 seconds , but the error occurs always.
    I can only publish 2 data, then I must reset

    here is the code..what is wrong? it's quote absurd. The code is so simple....

    from m5stack import *
    from m5stack_ui import *
    from uiflow import *
    import ntptime
    import wifiCfg
    import time
    from flow import ezdata
    screen = M5Screen()
    screen.clean_screen()
    screen.set_screen_bg_color(0xFFFFFF)

    data = None

    wifiCfg.doConnect('XXXXXXX"')
    wifiCfg.autoConnect(lcdShow=False)

    import random

    while True:
    data = random.randint(0, 100)
    try :
    ezdata.setData('XXXXXXXX', 'temp', data)
    except Exception as e:
    print(str(e))
    wait(30)



  • Hello @lmartu68

    I can use get multiple times but I see the same error as you after the second set command. Also at that state when running the same code again, my M5Core2 reboots.

    @m5stack : as ezData is of today it's fairly unusable with M5Core2 (haven't tried other M5Stack devices). What are we missing?

    Thanks
    Felix



  • @felmue
    Let’s hope for a solution.
    I’ve had a love hate relationship with M5stack devices. They’re awesome …. But they’re so buggy they drive me nuts!



  • @felmue
    hello
    not relevant this topic, but UIflow 1.9.1 is not downloading code to my devices, I'm getting a red error banner, with a check your api key or filename.
    API key is correct.
    I've tried reloading the 1.9.1 firmware, and getting a new api key for my device, but nothing.
    Yesterday everything was working fine.
    Do know if there Is there any way to get into contact with support? I'm pretty sure this is a widespread issue,.
    thanks
    L.