M5Stack FIre Wifi can not connect



  • Good evening.

    Today I got my M5Stack Fire, and I was trying to connect with my Wifi. Sadly this does not work yet. It's screens shows: "Problem. Not Connected to: SSIDName" after trying to connect.

    • I have tried baking in the SSID / Password when I update the firmware (1.4.5.1) and have also tried the method with using the M5Stack as a wifi accespoint + updating the credentials with my phone, but both methods fail.
    • I don't think I made a typo with the password, because I copy pasted that.
    • I do use the "_" symbol in my SSID name, could that be an issue?

    Is there some method to see why it's failing?

    For the time being I only used M5Flow to program with by the way. Luckily connecting with USB works properly.


  • M5Stack

    1. make sure your WiFi SSID not include "space" or other special symbol
    2. remove the battery bottom then try again.


  • My WIFI has some underscores ("_") symbols, because I have opted out from google using my wifi signal using “_nomap”. These are the only special character symbol I'm using. It's a bit difficult to change the SSID, because we have like 20 different devices using it.

    Is there some way to see if the name of my WIFI SIDD is the actual problem?

    Thanks for the quick reply by the way!