UIFlow 1.4.5

  • @illusion were you able to connect to wifi? offline wont work yet as the link for uiflow desktop hasn't been updated to 1.4.5 on the website, You cant upgrade it within the software either

  • @illusion said in UIFlow 1.4.5:

    and btw what is "app run mode"?

    When you start atom in app mode after boot a file main.py is running. In this file you can save your program which will be run. You can save your program from UiFlow by "Download" button/icon. Then your program should be saved as main.py and after restart device should be run it. But i did not tested by this way on atom (on StickC works as i wrote up). I wrote this file by another software.

  • Some issues about UIFlow 1.4.5/ on Atom Lite/Matrix :

    • using CLI (Command-Line-Interface) tools (on Linux), 'screen /dev/ttyUSB0 115200' on Linux works, showing 'MicroPython v1.11-301-gd0880874d-dirty on 2020-03-13';
    • but 'rshell' and 'ampy' don't work at all (these tools are useful to manage files on MicroPython microcontrollers). Exemple of error message : 'ampy.pyboard.PyboardError: could not enter raw repl';
    • so how to copy files to/from the internal flash memory of Atom Lite/Matrix ? I don't see webrepl, ftp server, etc, in the 1.4.5/ firmware.

    While using :

    • Atom Lite/Matrix with pre-installed firmware (MicroPython v1.12-36-gf68fe753b-dirty on 2020-01-14), 'rshell' and 'ampy' work without problem;
    • M5StickC with UIFlow 1.4.5/, 'rshell' and 'ampy' work too.

  • Could you try uPyCraft. I use them on windows system and i can transfer files to/from Atom Lite/Matrix with burned Uiflow firmware. Under linux where i use Linux Mint 19 uPyCraft i cannot run it (problem with installing proper libraries needed to run)

  • upyloader is another good solution for transferring files to the flash. Ampy hasn't worked for me for a long while

  • Thanks for both suggestions. I've tried uPyCraft on Linux and it works.

    But then I've remembered Thonny. Tried it and it also works on Linux and has many features for MicroPython @ Atom Lite : View->File, edit file on microcontroller flash memory, etc.

    I also recommend mpfshell, it works 100% on Linux to copy files with Atom Lite/Matrix & UIFlow 1.4.5(.1).

  • Since a few days an entry in a MAP of UIFlow is not entered in the MAP. In the Blockly view the entry is present, in the Python view it is missing. All other entries in this MAP are present.


  • I am not sure what happened, but the offline version 1.4.5 is confusing. At one point I could do PaHub but now with the current 1.4.5/1.0.9 I cannot select PaHub or PbHub. Am I missing something?

  • @wegunterjr you could select to the beta version (UIFlow 1.5.1) , this bug we will fix it as soon as possible.

  • @robalstona I cannot get a program to autostart in an Atom Matrix. I tried naming it "main", and also "main.py", but after I switch modes with button/reset and release at purple, the screen turns black and stays black through reset and power on.

    What am I doing wrong?


  • @dpharris

    in the FS root path has already had main.py file you could modify it. when you select the app mode(purple) main.py will be exec.

    if you are use UIFlow, you need to download the program, not just exec it. then it will auto setting this program for auto-start running.

    if still not work, pls check the serial log