Cannot Upload UIFlow 2.0 beta 14 to new CoreS3: "Error - Invalid Chip"

  • on a new CoreS3, after 3 seconds press on restart button, and after getting green light shortly, with M5Burner I then try to upload UIFlow 2.0 beta 14 (or beta 13), and I get a message "Error - Invalid Chip"

    Does someone else also encounter that problem?
    Is the CoreS3 defective (despite the demo app works good...)



  • I get report from CoreS3 Touch Panel Hot-Fix firmware below:

    M5CoreS3 TP FW Information
    regA1 Lib Version: 0x3008
    regA3 ChipVendorID: 0x64
    regA6 Firmware ID : 0x05
    regA8 CTPMVendorID: 0x02

  • @flex dumb question but caught me out, you did release the button after the green light came on?

  • Yes I did!!!

    And I was successful to update an AtomS3 and a StampS3.

    And I can erase or flash successfully the CoreS3 with the demo program on my configuration

    the only concern that I have is that my configuration seems to use esptool 3.32 when I use M5burner, while the latest available version of esptool is 4.51

    but I just made update of the AtomS3 and StampS3 with UIFlow Alpha15 without problem with same configuration, and I am just unable to flash the CoreS3.

    Could the CoreS3 version of UIFLow Alpha15, Alpha14 and Alpha15 compilations were done with some specific parameters different from AtomS3 and StampS3 or not on the same machine or by the same user?

    Which esptool version is called through M5burner on your configuration when you flash the CoreS3?

  • I’m running esptool3.3.2-dev on mine

    When the coreS3 is in boot loader mode, the port is called usb modem, when in UIFlow mode the port is called uiflow

    On my computer it does take a while for the CoreS3 to be erased before flashing

  • I am able to flash the demo app on the CoreS3

    I am able to set the config on the CoreS3
    I am able to erase the CoreS3, prior to the step of flashing
    but then,
    I am not able to flash UIFLow on the CoreS3, and get just at beginning of process, before even getting the log window, a message "Error - Invalid Chip"

    when I flash "CoreS3 Touch Panel Hot-Fix firmware", I get:
    M5CoreS3 TP FW Information
    regA1 Lib Version: 0x3008
    regA3 ChipVendorID: 0x64
    regA6 Firmware ID : 0x05
    regA8 CTPMVendorID: 0x02

  • my port on the core, prior flashing is:

  • which log do you have when flashing?

    maybe I can try to flash through the terminal...

  • Hi,

    I just thought also that I was not requested, at the flashing step of UIFlow, to bind my Core3S with my account, but just got that message "Error - invalid chip"...

    Could it be related to the binding step?

  • After investigations through terminal and

    • what I thought as successful the Erase and Flash of the demo app and the config prior to flashing UIFlow2, wasn't in fact successful:
      log windows were confusing in those case,
      but not when step of flashing UIFlow2, as more tests are done I am getting the message "Error Invalid Chip".

    It seems that the CoreS3 is DOA for flashing and can just run the demo app....

  • @flex

    Sorry for this happening, I believe that this problem may be caused by our failure to update the mac records of the database in time, we are optimizing our process, and I am very sorry again.

    If has any problem you can send the e-mail to me :-)

    yes it is solved now that MAC address was correctly registered in your server, and the binding process went through correctly, and therefore the burning or UIFLow...

    That takes me to a question:

    How could I unbind an S3 M5Stack device registered with an account, if I want another person with another account to take on it?


  • @flex just delete it in UIFlow to unbind it. I tried this out while writing the guide

  • Thanks, I'll give it a try to unbind, and then will try a rebind