UiFlow 2.0 Alpha verison discuss(how-to, bug, feature request or sometings)

  • Potential bug: When I add a function, any blocks in there seem to go "disabled" - I have to manually enable every bit of it. After saving and loading, all blocks are disabled again.

    Am I missing something?

    Thanks - JW


  • @jruys

    Sorry for that happened, we'll look into this.

  • Bug in "get UTC time"

    • year returned is +30 (2053 instead of 2023)
    • month is OK
    • day returned is -1 (17 instead or 18)
    • hour is OK
    • minute is OK

    Bug in "get system uptime in seconds"

    • value is increasing correctly second by second but the value returned is HUGE!!!

  • problem with some m5Burner version 3 on OSX:

    different versions where released on the website but they are all identified 3.0.0, which is confusing...

    • the one of April 9 2022, which doesn't work with atomS3
    • the one of January 13 2023 which works

    you should increased the last one to 3.0.1 to avoid any confusion for long time users



  • Hi,
    Could you unlock from UIFlow 2 the capability to code in micropython…

  • @flex What do you mean as you can work direct in micropython without UIFlow using REPL

  • @IAMLIUBO With the S3's having the internal USB adapter, the S3's can now act as USB drives.
    Can we get a UF2 boot loader so that Stamp and Atom S3's can now be programmed like Microbit and Circuitpython devices (USB storage devices.)

  • @ajb2k3
    UIFlow make it easier to upload and test code through the cloud and also to draft the screen UI on the atomS3

  • @flex
    And also rhrough the uIFlow cloud it is ok to develop through an ipad as it doesn’t offer USB-C to serial

  • @IAMLIUBO Error with the TOF Unit with Alpha7

    Connected to Serial Port!
    >>> import gc
    >>> gc.collect()
    paste mode; Ctrl-C to cancel, Ctrl-D to finish
    === import os, sys, io
    === import M5
    === from M5 import *
    === from hardware import *
    === from unit.tof import ToF
    === from unit import *
    === title0 = None
    === label0 = None
    === i2c0 = None
    === tof_0 = None
    === def setup():
    ===   global title0, label0, i2c0, tof_0
    ===   i2c0 = I2C(0, scl=Pin(1), sda=Pin(2), freq=100000)
    ===   tof_0 = ToF(i2c0)
    ===   M5.begin()
    ===   title0 = Widgets.Title("Title", 3, 0xFFFFFF, 0x0000FF, Widgets.FONTS.DejaVu18)
    ===   label0 = Widgets.Label("Text", 23, 58, 1.0, 0xffffff, 0x222222, Widgets.FONTS.DejaVu18)
    ===   title0.setText('TOF Unit')
    ===   label0.setFont(Widgets.FONTS.DejaVu9)
    === def loop():
    ===   global title0, label0, i2c0, tof_0
    ===   M5.update()
    ===   label0.setText(str(((str('Distance: ') + str((tof_0.get_distance()))))))
    === if __name__ == '__main__':
    ===   try:
    ===     setup()
    ===     while True:
    ===       loop()
    ===   except (Exception, KeyboardInterrupt) as e:
    ===     try:
    ===       from utility import print_error_msg
    ===       print_error_msg(e)
    ===     except ImportError:
    ===       print("please update to latest firmware")
    Traceback (most recent call last):
      File "<stdin>", line 28, in <module>
      File "<stdin>", line 23, in loop
      File "driver/vl53l0x.py", line 521, in get_distance
    AttributeError: 'VL53L0X' object has no attribute 'range'

  • @flex @IAMLIUBO @ajb2k3
    bug in "get UTC time" and "get system uptime in seconds" for AtomS3 and UIFlow2/micropython 1.19.1 is probably related to a confusion handling Unix time 1970 and Unix time 2000 (as 30 years difference returned)

  • @iamliubo can someone from M5Stack please check the AtomS3 GitHub “Issues”.
    I have one outstanding and another question to ask, but no one is there?

  • @flex Some people and groups cant use the cloud platform and so local programming like with the microbic and RPI is needed for them

  • @ajb2k3 said in UiFlow 2.0 Alpha verison discuss(how-to, bug, feature request or sometings):

    @flex Some people and groups cant use the cloud platform and so local programming like with the microbic and RPI is needed for them

    This is true. If you build an internal application for a company on the internal network, the devices will not have cloud access or they have to switch always the wlan.
    A Desktop uiflow version is still a good alternative to the cloud version !

  • Ui Flow 2.0 looks nice. But it lacks functionality.
    Tested with a new Core S3 and wanted to test out the built in Camera. But how to do it either in micropython or with blockly ?

    Once you start selling the devices, the software must be ready and support all features of the device.

    In my case I wanted to test the camera if it is possible to use the built in camera as a barcode reader, this would be a great application.

    Second question to uiflow 2.0: Where have the examples gone ?
    Even as an experienced programme, the demos are a good starting point for testing out a device or a unit.

    Third question: How about the support of the stackable-modules for the Core S3 ? How to access them in the UiFlow 2.0 ? can we reuse the modules for the older M5 Stack models ?

  • @sgu UIFLOW2 and the S3 generation are in alpha test only. From what I can see there are some issues with the pins that could mean that modules won’t work. There are no examples because none have been made yet. I am working on documentation but as UIFlow is in alpha and prone to change then documentation is slow going including the documentation of the various API’S buried in the firmware.

  • Hi there,
    I tried to do something but uiflow2 is somehow confusing:
    I was able to burn uifllw 2.0 on my atom s3 thank to adam!
    Now I wanted to play with it: so I changed the bacground colour! this worked.
    Now I was looking to other option as he one found for the stick C plus (IMU and so on) but those are0_1687691175164_uiflow2_ no option.png not available for the atoms3...
    0_1687691191201_uiflow1_ all options.png the second picture is from uiflow where all hardware options are listed... even the remote + options which is very promissing to me if I achieve that. but I cannot delete all at once...I cannot see the end of the window so I cannot delete everything...or clear to start from scratch on microsoft edge...
    boring somehow0_1687691546600_graph tempersture options.png

  • You need to click on "Hardware" under the picture of the Atom S3, then click on the hardware option to use it.IMU is there and was working.

  • I see- the page view was cropped too tight..
    I did reset those now I see those...
    this is idiotic but ar least I can get it now.
    I wanted to get the remote +
    Will it be enable in the future?

  • alas, I don't know