SOLVED: UIFlow cannot currently connect to any M5Stack devices

  • Same issue here - M5Stickc and Atom - all devices connect to Wifi but cannot connect to M5Flow via browser.
    Latest FIrmware and 1.7.8 UIFlow.

  • It seems to be working again, my browser now gets a connection to my device. So it was a server-side problem, nothing to do with our m5stack devices, firmware or API keys.

  • Hi guys

    works for me - tested with an M5Atom Matrix and an M5StickC Plus (both running UIFlow version 1.7.8).

    Maybe a temporal or regional issue?


  • @felmue It was "unconnectable" for about 24 hours, which was extremely annoying. The thing was that the devices could connect to the server and showed green connections. But the UIFlow server couldn't connect back to the devices.
    I didn't change anything at my end and now everything is working as before.
    I was trying to test the OLED Unit because of a brightness problem and that new unit is not yet supported in the desktop (offline) UIFlow IDE, so I had to be online and connected to try things out.

  • Is this happening again? Everything was going along well, but now ... even though my device shows as connected to the Cloud, and even though the API key checks out fine, every attempt to download code gives me the "failed" message. It was working earlier, but now I've gone through it again, and again, and again. Burned the latest version to the device. Tried both desktop and online versions. Can't connect.

  • Server is in China and prone to drop outs.

  • It seems to be happening again. Problem connecting from UK. This is beginning to discourage me from investing further in this system.

  • @gdallask Same thing is happening to me right now :(

  • @sodar have you tried changing the servers in M5Burner?
    There are quite a few people trying to access the same server which means someone will be refused a connection and then there is the Great Firewall of China which sometimes causes problems.

  • @ajb2k3 I was originally having issues with the other servers too, but it looks like it's working now.
    Thank you!