UnitV2 on MacOS

  • Re: m5stack unitv2 AI Camera - getting started
    How can it connect with MacOS?

  • Hi,

    Ideally, it should broadcast a wifi and you should be able to connect to it and navigate to the given IP address on the rear side of the unit in the browser. I tried connecting my UnitV2 with MacOS but the system does not detect the device and neither does it broadcast a wifi. Same problem with one more person here.

    I think M5 has shipped the devices without testing

  • Hi, before use, you need to install the driver for it.

    For more detail, you could refer to this tutorial


  • Thanks for the link to driver, but I see no network adapter in my terminal when I connect the unitv2 after successfull installation of the driver. any other resort to check this?

  • Driver is not working out-of-the-box. Already installed on MacOS but it didn't show the UnitV2.
    The PDF guide inside the zip file suggests to disable SIP on Mac, I'm not going to do that.
    Also tested on a very old Windows 7 PC. I can install the Widnows driver and I see the unitv2.py window but it gets stuck with a loading... message.
    AP hotspot is not working in any case, I can't see the M5UV2_[XXX] SSID on my WiFi network list.
    Is there I am missing?

  • Im on mac and having the same issues, no wifi to connect to.

  • I have 3 points to write here.

    1 = Mine fails to work like @MTal says.
    2 = With Jupyter, capture failes once per every two trials.
    3 = How to get SD card initial image to be dd-ed?

    From OSX, I successfully connected to my unitv2 bought at Japanese store (switchscience) last week, but like @MTal says, loading does not stop like below.
    0_1625457521062_スクリーンショット 2021-07-03 16.08.33.png

    Actually I managed to see the UI once, but could not try camera demo, so I tried Jupyter mode, and successfully ran samples, but camera capture failed once per two times using sample code embedded:

    import cv2
    camera = cv2.VideoCapture(0)
    ret, frame = camera.read()
    if ret:
        print('Capture Successful!')
        print('OOps, we get some trouble!')

    I'm not sure this is related to infinite "loading...".

    I'm not sure this is caused by SD card corruption or not,
    but if anyone know how to get initial SD card image, I'd like to flash by myself to try fixing it.


  • What browser are you used? this function use with Safari has some compatible issues. so maybe you could try to use chrome