Updated: M5StickC + 18650C HAT: Heat & LCD corruption

  • Hello Everyone,

    I just acquired one of these nifty units (AliExpress) however I've run into an issue I don't seem to be able to resolve. I tried emailing support but have not heard back so I joined and figured perhaps the community can help me.

    I have the M5StickC (blue 5V sticker on the base where the pins are; I don't know which version this is) and the 18650C HAT (v1.3 is shown in the battery compartment) and while I had to charge up my M5StickC (Error 22) I was able to flash OpenMQTTGateway on it without issue and it works perfectly fine.

    My issue is when I connect the M5StickC to the 18650C HAT (and put 2 machine screws into the base to hold it in place) and put a battery in (I have lots of 18650C batteries) two things happen:

    1. The M5StickC starts to get REALLY warm, I mean noticeably warm and you can smell "burning electronics" -- sort of a coppery smell.
    2. The screen on the M5StickC starts to show this black "creeping" circle that slowly starts expanding across the LCD display

    Of course I don't let this sit this way and disconnect everything. When I connect the M5StickC with the supplied USB-C cable from my laptop, everything works fine. No heat, no creeping black on the LCD.

    I don't know what I'm doing wrong here. I'm beginning to believe that either I have mismatched units or there's a defect but since I just got this, I'm not sure where to start troubleshooting. Am I running old firmware on the M5StickC perhaps? I really don't know where to begin.

    Can anyone provide any advice?


    EDIT: I did some more testing and came to the following conclusions:

    • Any 18650C battery including the blue one it's shipped with produces same results
    • Leaving the battery out and connecting through the base USB-C port, the unit powers up and works as expected.
    • I tested with and without the machine screws installed, made no difference in results (I read a post here where someone said the screws interfered with the M5 button)

    Pictures I took:

  • Hello @flatline69

    Sorry to hear about your troubles.

    Please note: I only have an M5StickC but no 18650C HAT so I cannot fully recreate your setup. I also have not been able to find a schematic for the 18650C HAT so I am guessing about how it is connected with the M5StickC.

    One thing that is not clear to me is whether the 18650C HAT can charge its battery on its own, e.g. w/o M5StickC installed. Does it have its own charging IC?

    Also you mentioned Error 22. Did you ever get over that? I mean does your M5StickC run from its internal battery w/o being installed into the 18650C HAT?

    Have you tried to reinstall the factory test firmware the M5StickC came with? It might be worth doing that and check if the heat issue with the 18650C HAT still occurs.

    Also do you happen to have a USB voltage/current meter? If yes, it might be worth measuring the charging current. For the M5StickC it is normally set to about 100mA in function Axp.begin() since its internal battery only is about 90mAh. But if that function is not called (for whatever reason) the Axp IC defaults to 780mA.

    And last question: Did you measure the voltage of your 18650 battery? Does it already have some charge?

    Since I am mostly guessing here and my assumptions could be completely wrong it might simply be that either your M5StickC and/or your 18650C HAT is/are defective.

    Good luck!

  • @flatline69 ,

    I just tested your setup, I have several M5StickC with blue 5V sticker and also two 18650C HAT.
    I built the M5StickC with blue 5V sticker two pieces and the two 18650C HAT together and also screwed them together. But the M5StickC don't get warm!

    Either, as @felmue writes, it is because of the charge current if it is not set to 100mA.
    Otherwise it would be interesting which version of the 18650C HAT you have, because there are probably 2 versions of it. Unfortunately there is no version imprint in my version, but according to the documentation there should be no difference except for the additional mounting option.

    So I guess in the end:

    1. the charge current in the M5StickC is higher than the 100mA.
    2. because you got an (Error 22) message that the internal battery is defective (deep discharge)
    3. the M5StickC is defective (internal battery defective)
    4. the 18650C HAT is defective, loose or defective components on the board lead to your result!

    Good luck skink

  • @felmue

    You write (One thing that is not clear to me is whether the 18650C HAT can charge its battery on its own, e.g. w/o M5StickC installed. Does it have its own charging IC?)

    The 18650C HAT is charged exclusively via the USB port, no M5StickC is required! The USB port is only for charging, otherwise the USB interface has no function!

    Greeting skink

  • Hello @Skink

    thank you for the clarification. I appreciate it.


  • @skink

    Are you sure the 18650C hat has its own charging circuit?
    I thought we had to connect the M5StickC for the charge to be managed by its AXP192 controller?
    Also, how do you know when the charge is complete? Is there an indicator LED for this?


  • The 18650C itself has a battery built in, do you mean you took it apart and put in your own battery?