UIFlow on core 2

  • Hello,
    Today tried to use M5Burner on my Mac osx Catalina 10.15.6. M5Burner starts, shows a screen but this doesn't resemble the screenshots on any forum or tutorial and I can not select a firmware to flash.
    So I have found https://github.com/m5stack/M5Cloud/tree/master/firmwares . Is this the firmware to use for UIlow and can I program it with esptool ? Is it already compatible with the core2?
    Thanks in advance for shedding a bit of light for this cool product with a lot of confusing documentation..

  • What do you mean "this doesn't resemble the screenshots on any forum or tutorial"

  • it can't loading the firmware list ? could you show a screenshot ? which area location are you in? make sure the internet normal , or try to use VPN.

  • I have tried it on a windows laptop and now I see that the osx version doesn't show the available apps. See screenshot below. Windows is working and I am on the same network with both laptops

    0_1603276771096_Schermafbeelding 2020-10-21 om 12.39.14.png

  • on an unrelated subject: the display of my M5Stack Core (not the 2) only works once every day at the first startup. After a reset the screen is black and stays black. I have to turn off the unit and wait until the next day before the screen shows the last program I have flashed again. Any idea?

  • Is it the M5Burner has been put in Applications directory?

  • I have copied it to Applications now and it works! Why is that?

  • I had the same issue, first tried to run it from the Downloads folder.

    Maybe M5Stack can add the information why it has to be in the Applications folder.

    Please move this app into Applications directory.
    Otherwise the firmware images can not be loaded.


  • MacOS users please put M5Burner App in the Application folder after the installation as shown in the figure below.