Cant run M5Burner in Linux



  • I cant start the new M5Burner on Ubuntu 18.04.4 LTS. I get a JavaScript error:
    GLIBC_2.28 not found
    Please help.


  • M5Stack

    Are you using standalone burner or firmware burner within uiflow desktop ide? I suggest you use the latter, I had no issues flashing devices this way on ubuntu 18



  • @xis said in Cant run M5Burner in Linux:

    I cant start the new M5Burner on Ubuntu 18.04.4 LTS. I get a JavaScript error:
    GLIBC_2.28 not found
    Please help.

    Have you updated GlibC to 2.28?


  • M5Stack

    thank you feedback. we will fix this problem as soon as possible



  • Thank you for the help.
    So, using uiflow desktop ide there is another error:

    Chip is ESP32-PICO-D4 (revision 1)
    Features: WiFi, BT, Dual Core, 240MHz, Embedded Flash, VRef calibration in efuse
    MAC: d8:a0:1d:56:b9:b8
    Uploading stub...

    A fatal error occurred: Timed out waiting for packet header

    Burn Failed

    How can I update GlibC to 2.28?


  • M5Stack

    Which baud rate did you use? for M5stickC and M5atom you should use baud rate 750000, make sure the correct serial port is selected and that you have erased the device before flashing.

    Edit - also not sure if you already know this but using esp32 devices on linux you need to add the current user to the dialout group in order to access the port that the device is connected to. Open up a terminal and enter these commands

    Sudo usermod -a -G dialout $user
    Sudo chmod a+rw /dev/ttyUSB0
    


  • Connecting........__.....
    Detecting chip type...
    A fatal error occurred: Timed out waiting for packet header

    Erase Failed

    That is using 750000 baud rate.
    User is on the dialout group.
    Arduino IDE works. And also the last version of M5Burner used to work.


  • M5Stack

    @xis the software has been updated. you could download a new one, then try it again.



  • Works great. Thank you so much :)