M5Stack after loading the program is still restarting.



  • I have M5Stack.
    When I compile my program for Arduino 1.8.12, windows 7 32 bit and I do download with G0 = gnd with a speed of 115200, the program restarts in a circle.
    Other speeds don't work.
    below the log from the terminal

    rst:0x1 (POWERON_RESET),boot:0x17 (SPI_FAST_FLASH_BOOT)
    configsip: 0, SPIWP:0xee
    clk_drv:0x00,q_drv:0x00,d_drv:0x00,cs0_drv:0x00,hd_drv:0x00,wp_drv:0x00
    mode:DIO, clock div:1
    load:0x3fff0018,len:4
    load:0x3fff001c,len:1216
    ho 0 tail 12 room 4
    load:0x40078000,len:9720
    ho 0 tail 12 room 4
    load:0x40080400,len:6352
    entry 0x400806b8

    M5Stack initializing...<0><0><0><0><0><0><0><0><0>
    Booting device...
    Reading settings from eeprom.
    Settings not found. Initialization.
    Settings saved to eeprom.
    Init TFT display
    merged:6101FFF8000009285A3B0648030000B4179D763404080805000000
    merged:62B002E0000000FFB400330B0000000000000000
    Start BLE with PIN auth
    ets Jun 8 2016 00:22:57

    rst:0xc (SW_CPU_RESET),boot:0x17 (SPI_FAST_FLASH_BOOT)
    configsip: 0, SPIWP:0xee
    clk_drv:0x00,q_drv:0x00,d_drv:0x00,cs0_drv:0x00,hd_drv:0x00,wp_drv:0x00
    mode:DIO, clock div:1
    load:0x3fff0018,len:4
    load:0x3fff001c,len:1216
    ho 0 tail 12 room 4
    load:0x40078000,len:9720
    ho 0 tail 12 room 4
    load:0x40080400,len:6352
    entry 0x400806b8

    M5Stack initializing...<0><0><0><0><0><0><0><0><0>
    Booting device...
    Reading settings from eeprom.
    Settings not found. Initialization.
    Settings saved to eeprom.
    Init TFT display
    merged:6101FFF8000009285A3B0648030000B4179D763404080805000000.........


  • M5Stack

    @spairo why you connect the G0 --> GND ?and which device are you use? M5Stack download program don't need G0-->GND. it differ other dev board



  • I have m5Stack, a small black box with three silver keys and a TFT LCD display.
    I can't load anything into m5sstack if I don't give G0 then GND.
    I use 7 Pro x32 Win and I use Arduino 1.8.8 or 1.812.
    I don't know any other way to program m5Stack under Windows



  • after download m5stack-ble black box is resrating in loop with register dump.

    Rebooting...
    ets Jun 8 2016 00:22:57

    rst:0xc (SW_CPU_RESET),boot:0x17 (SPI_FAST_FLASH_BOOT)
    configsip: 0, SPIWP:0xee
    clk_drv:0x00,q_drv:0x00,d_drv:0x00,cs0_drv:0x00,hd_drv:0x00,wp_drv:0x00
    mode:DIO, clock div:1
    load:0x3fff0018,len:4
    load:0x3fff001c,len:1216
    ho 0 tail 12 room 4
    load:0x40078000,len:9720
    ho 0 tail 12 room 4
    load:0x40080400,len:6352
    entry 0x400806b8
    M5Stack initializing...OK
    Guru Meditation Error: Core 0 panic'ed (LoadProhibited). Exception was unhandled.
    Core 0 register dump:
    PC : 0x4010512d PS : 0x00050031 A0 : 0x4008565c A1 : 0x3ffbe360
    A2 : 0x00000000 A3 : 0x3ff48044 A4 : 0x800e04be A5 : 0x400916e8
    A6 : 0x00000000 A7 : 0x40085fb0 A8 : 0x00000000 A9 : 0x3ffbb700
    A10 : 0x00000000 A11 : 0x3ffbbd60 A12 : 0x800e04b3 A13 : 0x3ffbc010
    A14 : 0x00000000 A15 : 0x3ffbc03f SAR : 0x00000016 EXCCAUSE: 0x0000001c
    EXCVADDR: 0x00000000 LBEG : 0x00000000 LEND : 0x00000000 LCOUNT : 0x00000000
    Core 0 was running in ISR context:
    EPC1 : 0x4010512d EPC2 : 0x00000000 EPC3 : 0x00000000 EPC4 : 0x00000000

    Backtrace: 0x4010512d:0x3ffbe360 0x40085659:0x3ffbe380 0x40185037:0x3ffbc060 0x400e1a02:0x3ffbc080 0x40090745:0x3ffbc0a0 0x4008ef51:0x3ffbc0c0

    Rebooting...
    ets Jun 8 2016 00:22:57

    rst:0xc (SW_CPU_RESET),boot:0x17 (SPI_FAST_FLASH_BOOT)
    configsip: 0, SPIWP:0xee
    clk_drv:0x00,q_drv:0x00,d_drv:0x00,cs0_drv:0x00,hd_drv:0x00,wp_drv:0x00
    mode:DIO, clock div:1
    load:0x3fff0018,len:4
    load:0x3fff001c,len:1216
    ho 0 tail 12 room 4
    load:0x40078000,len:9720
    ho 0 tail 12 room 4
    load:0x40080400,len:6352
    entry 0x400806b8
    M5Stack initializing...OK
    Guru Meditation Error: Core 0 panic'ed (LoadProhibited). Exception was unhandled.
    Core 0 register dump:
    PC : 0x4010512d PS : 0x00050031 A0 : 0x4008565c A1 : 0x3ffbe360
    A2 : 0x00000000 A3 : 0x3ff48044 A4 : 0x800e04be A5 : 0x400916e8
    A6 : 0x00000000 A7 : 0x40085fb0 A8 : 0x00000000 A9 : 0x3ffbb700
    A10 : 0x00000000 A11 : 0x3ffbbd60 A12 : 0x800e04b3 A13 : 0x3ffbc010
    A14 : 0x00000000 A15 : 0x3ffbc03f SAR : 0x00000016 EXCCAUSE: 0x0000001c
    EXCVADDR: 0x00000000 LBEG : 0x00000000 LEND : 0x00000000 LCOUNT : 0x00000000
    Core 0 was running in ISR context:
    EPC1 : 0x4010512d EPC2 : 0x00000000 EPC3 : 0x00000000 EPC4 : 0x00000000

    Backtrace: 0x4010512d:0x3ffbe360 0x40085659:0x3ffbe380 0x40185037:0x3ffbc060 0x400e1a02:0x3ffbc080 0x40090745:0x3ffbc0a0 0x4008ef51:0x3ffbc0c0

    Rebooting...
    ets Jun 8 2016 00:22:57



  • Problem has been solved
    The weak USB cable was to blame, after replacing the cable with the original Samsung, the problem did not return.
    Problem messages are:
    "BrownOut detector was triggered" and
    "The Guru Meditation" something like Blue screen of Death (BSOD)