M5StickC/ATOM on MacOS Catalina can't upload/ ESP32: Timed out waiting for packet header solution (Solved)

  • @m5stack

    No, the is (un)fortunately no Windows machine. I'm a little confused about the fact, that the above mentioned firmware is running without any problem. So there needs to be a connection between mac to m5atom in some way — or how is it writing to the device?

  • My new m5stick-C are showing up on the MacOS (10.15.3) as M5 Serial Converter, and in the Arduino IDE (latest edition). I have applied the updater as suggested in this thread, and still get this response when trying to upload from the IDE to the device: "fork/exec /Applications/Arduino 2.app/Contents/Java/tools-builder/ctags/5.8-arduino11/ctags: bad CPU type in executable
    Error compiling for board M5Stick-C."

  • @rschdev clearly. this is a compiling error . you should check the error information , and check you program.

  • @herrlehmann did you installed the FTDI driver? you could try delete both below files. then connect your device try again.


  • @m5stack said in M5StickC and ATOM on MacOS Catalina can't upload programs solustion:


    I had access to a Windows machine and was able to use the easy loader on my M5Atom Matrix. It is working on Windows.

    For my mac:
    Yes, I installed the FTDI driver, but they did not work. I've removed them as suggested, but it didn't change anything. There is still no device appearing in /dev/, so it is not accessible.

  • @m5stack did you dig any deeper into this? I'm still unable to use the M5Atom Matrix on my mac with Catalina. I started over again by installing and deinstalling stuff, but no new device appears. The system recognizes the M5Atom Matrix by naming a M5 Serial Converter with following information:

    Produkt-ID: 0x6001
    Hersteller-ID: 0x0403 (Future Technology Devices International Limited)
    Version: 4.00
    Seriennummer: 79525701B4
    Geschwindigkeit: Bis zu 12 MBit/s
    Hersteller: M5STACK Inc.
    Standort-ID: 0x14500000 / 6
    Verfügbare Stromstärke (mA): 500
    Erforderliche Stromstärke (mA): 100
    Zusätzlicher Betriebsstrom (mA): 0

    I also applied the firmware update many times successfully.

    @m5stack : Any other ideas? I'd like to play with it.

  • @herrlehmann did you have try to install the FTDI driver : https://www.ftdichip.com/Drivers/VCP.htm

  • @nsfilho don't update to 10.15.04....

  • @m5stack : Yes, I did. By further investigating the driver, it looks like they are not working due to signing issues. I found this thread https://www.ftdicommunity.com/index.php?topic=409.msg1171#msg1171

    I'm waiting on this rerelease, than I'll let you know. Thanks.

  • I'm trying to apply firmware update on Catalina and having this error message:

    Detecting M5Stack products.
    Find M5Stack products.
    Kernel driver deteched.
    Apply magic success.

    Fail to cast magic stage 2, please contact vendor
    Wating for device in DFU mode..................................

    Any idea?

  • @climbingrose I have same problem. Have you found any solution?

  • @climbingrose I have that same problem as well. It would be nice if @m5stack could support their products in a better manner and give us a good receipt to fix the issues.

  • @finnsen if you try these solution still can't solve the problem. you could contact the store

  • @m5stack What do you mean by contacting the store, how can they help me resolve the issue? Or do you mean to return the product?

  • @finnsen I didn't catch what you were trying to flash to your device, if you are trying to update uiflow firmware on the device with M5Burner and it fails, have you tried using esptool to flash firmware? if you were uploading an arduino program there are known issues with all esp32 devices on catalina not just m5stack https://github.com/arduino/Arduino/issues/9438 I did make a video a while back ( https://www.youtube.com/watch?v=MTCjKhVKOto) about using m5stack devices on catalina and I didn't seem to come across any of the issues you mentioned, perhaps the issues are with a later revision of catalina, I'll update and take a look when I get chance.

  • @finnsen I mean, If above these solutions still cannot be solved, even if change the computer system(use win10) , use the different flash tool, setup low upload speed(baud 115200), it cannot be solved, then there may be a product problem. Please contact the store for a replacement. and, we recommend that you use the official version of the operating system, not the preview/beta version. In some preview versions, the driver will not work properly

  • @lukasmaximus Thank you for your video. I did not know about setting the device in USB mode as you video explained. I am now getting things to work. Thanks. :)

  • @m5stack My issue where not knowing about setting the Atom Lite in USB mode. And I got confused about the USB firmware upgrade that you described in your initial post as I get the error message that the Update program is not able to set the device in DFU mode. Anyways, things seems to work. Thank you.

  • @m5stack: I finally fixed "my" problem being not able to "see" the Atom Matrix on a mac with 10.15.x!!! At first I suspected a Wacom tablet driver which interferes with my serial port, but at the end it was an old FTDI driver helper named D2xxHelper. I figured out the problem by issuing this command

    sudo ioreg -lirc IOUSBHostInterface

    It gives detailed information on the USB connections and its drivers. For the "M5 Serial Converter" it stated the the D2xxHelper as driver (helper). By removing this old driver and rebuilding the kernel cache I was finally able to "see" my Atom Matrix on Catalina. Enclosed my commands:

    sudo rm -rf /Library/Extensions/D2xxHelper.kext
    sudo kextcache -i /

    After this I've rebooted my mac.

  • @m5stack

    Hi, I have two M5Stick-Cs purchased in the same lot, one succeeded in updating this firmware, the other failed. The error display is as follows. Is there any countermeasure?

    % ./Updater_FW20200422

    ==================== M5 Serial Converter Firmware Updater ====================

    FW Version: ft232_OD_20200422


    Press enter to continue . . .

    Detecting M5Stack products.
    Find M5Stack products.
    Kernel driver deteched.
    Apply magic success.
    Waiting for device in DFU mode...
    Find M5Stack device in DFU mode.
    Traceback (most recent call last):
    File "m5stick_firmware_upgrader_OD_20200422.py", line 97, in <module>
    File "site-packages/usb/core.py", line 869, in set_configuration
    File "site-packages/usb/core.py", line 102, in wrapper
    File "site-packages/usb/core.py", line 148, in managed_set_configuration
    File "site-packages/usb/backend/libusb1.py", line 794, in set_configuration
    File "site-packages/usb/backend/libusb1.py", line 595, in _check
    usb.core.USBError: [Errno None] Other error
    [6711] Failed to execute script m5stick_firmware_upgrader_OD_20200422