Battery fix found (sort of)

  • I bought an m5 from amazon. After the initial hurdles to get serial recognized on my mac, i got it running a few programs. Very neat device.

    Then less than 24 hours later, the battery stopped working. I was able to run it off usb directly (from wall or computer) but not the battery. I assumed the battery or unit was defective and began process of research for solution before return.

    Step 1- test if battery is burnt/dead

    First I tested battery plate with multi meter. I took apart the 4 screws using normal (tiny) allen hex wrench. Then flipped over. I saw solder points from battery to 'GND' and "battery".

    I put negative/ground/black multimeter to "GND" point off battery solder point, and red on the 'battery' point. I found it working well at around 4 volts

    Next I tested the pins out from battery with mulit meter. No problem.

    Next I connected some pins out from battery directly into the lcd face using some header pins. I connected it to GND and 3.3 v. I then tested that connection with multimeter. Very flakey connection.

    So i found problem to be with LCD face .

    Step 2: Solve with wires.

    If battery works, i just then used 1 wire from kit. I connected battery to 3.3v. And it worked!

    I was willing to live with this solution but it would require me to have that wire and i dont know if i was doing things wrong.

    Step 3- Bend header pins on lcd face plate

    Now what i did was two pins outwards. First is battery and the other is 3.3. Battery is on bottom and 3.3 is 6 down from top. Just look at chart on the chip itself.

    I got nose pliers and slighty pushed out the pin so it would provide more friction with unit when closed.

    I then closed unit....and NOT WORKING!


    Step 4 - Solution!

    So i went back to my wire hack. This time when it powered on i pressed the case firmly down. The i removed the wire. I was expecting it to turn off...but no it stayed on!

    So i removed the wires, and now its once again running off battery power!

    BUT - about 3 minutes after I write that, the device is dead again.

    So now i will try to charge battery overnight. Perhaps its the small battery capability? It will be ridiculous if the base unit can only run for a few minutes. Not a good way to upsell people to the bigger battery

  • @m5dude I have the same problem and I believe it is related to the charger/power control chip used in the M5Stack and the “reset capacitor” issue. New, my 2018 M5Stack seemed to work well but the battery behaved like yours. Then, it wouldn’t reset properly until I put a 0.1uF capacitor between the RST and GND pins on the bottom plate. That worked for a week but now, not only does it not work, even without the bottom plate, I have problems resetting the M5Stack. I believe it is a design flaw in the charger/power control circuit or a flash in the chip used.

  • @pkourany

    I was thinking this would be solved if i got the bigger battery but sounds like it will lead to the same problem.

    i will hold off on buying the bigger battery if it will lead to the same broken behaviour

    maybe @m5stack can give some clues as to when/how this will be fixed?

  • @m5dude

    Day 2 after my hack fix. No prob with M5. The battery is now charging properly. I will order the bigger battery. Plus my proto stack is coming in soon. yipee!

  • @m5dude, which one was your working hack?

  • @pkourany

    its hard to know LOL

    but here is everything i did (now from memory)

    1- try charging M5 overnight with high power USB charger (fail - battery not working)
    2- power M5 by 1 wire from Battery to 3.3v (success - M5 boots up)
    3- spread out pin on M5 - i believe I did grn and battery (fail - M5 not working with battery)
    4- scream out loud (fail - but stress level reduced)
    5- scream out loud and squeeze M5 case hard (success! - M5 works with battery)

    so i think the solution was spreading the pins and squeezing it together. The connections on the M5 core are weak.

  • @m5dudeBattery fix found (sort of) 中说:

    so i think the solution was spreading the pins and squeezing it together. The connections on the M5 core are weak.

    the same as I wrote here:
    and here: