Brownout detector was triggered

  • Hello,

    I've started porting software to the M5Stack and everything was going good until I connected a replay module to the wrong pins and I started getting the following from the monitor session;

    ets Jun 8 2016 00:22:57

    rst:0xc (SW_CPU_RESET),boot:0x17 (SPI_FAST_FLASH_BOOT)
    configsip: 0, SPIWP:0xee
    mode:DIO, clock div:1
    entry 0x400789f4

    Brownout detector was triggered

    This repeats non-stop. In the past I had a cheap DOIT ESP32 board and occasionally get the same message when it tries to turn on the WiFi. The solution was to unplug the board and let it cool down for a few minutes. This is not working with the M5Stack.

    Does anybody have a solution for this?


  • @claude Hi Claude,

    I wonder what software you are porting over ??

    No definite specific solution for you but some leads......

    This link shows same error message as yours - occurred when running the SimpleBLE example... (not on M5Stack).

    Does your code load BLE or BLE and wifi ? Although, I know others have used BLE on M5Stack apparently without this issue.

    I presume you have dis-connected the relay module - still getting the error - yes ?
    Have you tried loading a basic known working sketch ?

    Two more relevant links:

  • I had a similar issue after short circuit (on other esp32 board).
    In my case the schottky diode was damaged and power supply drop voltage on this diode was too high for correct operation. Replacement of the diode solved the problem.

  • @JimiT, the software is a Google Home enabled thermostat with a 7 day programmable heating schedule. I have it running on two different boards right now (DOIT ESP32 and Heltec ESP32 with OLED). I wanted to port the code to the M5Stack and got half way thru porting the code before it started misbehaving.

    I found a post here about a user who had similar problems and built a push button jig that would ground GPIO 0 to force the unit into bootloader mode. I tried the same and sadly, that did not work for me. Now when I connect the monitor program and hit reset, I get garbage characters and not ESP boot message. I've tried different baud rates but can't see the boot message.

    When I try to upload a sketch, it gives me a message that the EEPROM size can't be determined and hangs after loading the bootstrap loader. I had a similar program with another ESP32 board and it turns out that the EEPROM was fried.

    The links you've posted are all good but once the unit goes into Brownout, it will not allow you to upload any sketch in the Arduino IDE. I've yet to find a Espressif command line program to clear the brownout condition.

    I think this unit is bricked :(

    @reaper7 Thanks for the info. Perhaps the people at M5Stack can provide me with some help here...