Members Introductions aka The Icebreaker discussion.

  • Apparently I am dislexic (sp). The driver version is

    Is my problem Windows 10? Should I try this on a 32-bit Windows 7 machine?

  • @Hamster to set the record straight Maixpy is not developed by M5Stack and is only intended to be used with Stick V. It is possible to open a serial terminal in Maixpy and code M5Stack devices from the REPL, but there are much better ways for doing that.

    I just wanted to double check, when you used vscode did you set your M5Stack into USB Mode?

  • Yes, I set the M5Stack in USB mode.

    I installed the toolchain for programming the M5Stack using VSCode in Windows 7 32-bit. The doohicky at the bottom of the VSCode window for adding an M5Stack did not even show up.

    I have been able to REPL to the device using PuTTY without issue.

    At this point, I think I need to move on. I am using a Visual Micro plugin for Visual Studio to develop using C++. Have I mentioned that I really wanted to use MicroPython instead? I'm much more versed in C++, but I wanted an excuse to learn Python. Oh, well.

    I know that the ESP32 has not been out that long and it is amazing what can be done with it. I'll check on MicroPython for the M5Stack in a few months.

    Thanks again for all your help!

  • Hi 2 All,

    I'm Red_Ant from Germany.
    I thought, it's time to start experimenting with these Arduino/ESP/whatever stuff, and I'm honest, I'm a real newbie. For that reason I decided to buy the M5Stack IoT StarterKit (white device).
    First hurdle was the setup of the editors ... I'm running Linux Mint.
    No chance to get it running ... so I switched to WIN10 ... no chance. Finally I figured out, that the short USB cable of the starter kit doesn'twork. With my Samsung phone line, everything worked fine.
    Great .... but
    Next I started with the sample app, already installed on the M5 ... ok, sensor on port A worked fine.
    But on port B, I wasn't able to get any of the other sensors running ... no feedback signal.
    I also found the explanation: no 5V on port B or C. Connecting the sensors to the 5V of port A (only 5V and GND) and all sensors worked fine.
    After all this, I thought to be ready for my first program ... so I give it a trial.
    What to say ... of course no success ... something with "uiflow lib missing".
    I also figured out, what's the problem: very old firmware.
    And after updating the firmware everything was fine ... except the missing 5V on port B & C.
    Any ideas ? Is there a switch to turn it on ? Setting/parameter/ ....

    Currently I've got the feeling, that I have to return the device.

    (Buy the way: in parallel I started with an Arduino ... without any trouble)


  • Be very careful with the units. They have colour coded connectors and only work with matching ports.

    How do you know that there is no 5v on the other ports?

  • Hi ajb2k3,
    I measured it with a multimeter ... no I didn't put the probes into the connector ... first I applied the original grove cable to the M5 and then extended it by breadboard cables, where it was easy and safe to connect the multimeter.
    And so I did for all three ports ... only on port A 5V could be seen

  • @red_ant Is the base fitted securely and squarely to the face plate?

  • @ajb2k3 ,

    I think so ... the screws seems to be tightened

  • @red_ant
    Do the leds on the side of the base work?

  • @ajb2k3 ,
    shall we continue this discussion somewhere else ? Move it to another place in the forum ?

    Regarding the question ... I can't see any LEDs

  • Hi,

    I am José, from France.
    Congratulations for M5 Stack and for the all the community projects.
    Interesting in M5 Stack starter kit.
    I imagine, only online.

    Have a great time with M5 Stack

    [fr] Bonjour,
    Je suis José de Troyes, France.
    Félicitations pour M5 Stack et pour les projets de la communauté :).

    Je suis intéressé par un kit de démarrage M5 Stack
    J'imagine qu'on le trouve uniquement en ligne.

    Bonnes fêtes de fin d'année :)


  • @lastcaress Hey Lukas, I have just implemented a M5Stack-C Project for Orientation during sleep that works fine. Is there a place where we can share our programs? Did not find that. yet.

  • @mchack there is the project forum designed just for that!

  • @ajb2k3 Jup, I found it and created my project on :)

  • @mchack said in Members Introductions aka The Icebreaker discussion.:

    @ajb2k3 Jup, I found it and created my project on :)

    there is also a project section of the forum just for this!

  • I am My name is Mehwish and I am also new here. hope we will spend a good time here.

  • Hiya, My name is Matthew, I'm in love with M5Stack products, they're not too publicly discerning, and allows me to move my projects around with ease! I love AI and I have 3x m5 sticks, each one has its own uniqueness and I love trying to make things work with them, like my tello drone.
    I'm still learning about unitv2 but when they update the firmware for the access point i'll be able to have a lot more fun! - See you all on the stackside!

  • Hi Adam,
    I am french living in Zurich and interested in dIY stuff I own 2 3d printer and having 2 that are dust trap (one is broken ( a crap m3d printer micro...not repaire-able ) but ok... I design more than 70 opensource design to be 3d printed.... I have assembled a nerdy gurdy for which I designed additionnal thingiverse models... I am active on the prusa community forum... I wanted to programm a xyz accelerometer export to enable easy instant shaping...

  • What's your thingiverse?
    I'm other as CPT_James_Purcell

  • I just search for you on thingiverse not able to find you
    look for "micro handle repair with storm Mando helmet low poly"
    did you made a design? what tittle?