Mounting SD Card

  • Hello,
    I recently received several (6 actually) M5Stack devices. After doing the capacitor mod, I've been able to download and test the supplied demos. Working with the FactoryTest sketch, I'm having problems mounting the SD Card. Here is my serial debug output:

    [W][sd_diskio.cpp:137] sdCommand(): no token received
    [W][sd_diskio.cpp:137] sdCommand(): no token received
    [W][sd_diskio.cpp:137] sdCommand(): no token received
    [W][sd_diskio.cpp:471] ff_sd_initialize(): GO_IDLE_STATE failed
    [E][sd_diskio.cpp:739] sdcard_mount(): f_mount failed 0x(3)
    Card Mount Failed

    I've tried other SD Card sketches with no luck. I've tried formatting (Windows & SD Formatter App) three different 3 (64gb microSD) sd cards also no luck.

    Any help would be appreciated!

  • There might be some size limitations, I know that Arduino in general (avr versions) only accepts up to 8GB, If you have a smaller card, maybe 16 or 8 GB try one. And if I don't rember wrong I think it needs to be formated as FAT

  • I am facing the same problem with the SD card mount. I tried with a 8GB FAT formatted SD card as you suggested but no luck.

  • @abhishek Hi my working micro SD card is formatted for FAT32 and is 16 Gb - which is the max recommended size. I'm using Sandisk Ultra.

  • Thanks for pointing me to the right way to access the SD card.
    Samsung 32GB passes the write/read hello.txt
    It's this model:
    It took me 2 days to pull the trigger on it because when the cpu is $40, it feels wrong to pay $12, but look at the adapter, and the speed, if the SD controller isn't the bottleneck it's well worth it.

  • @daslolo Thanks for confirming a 32 Gb card works.... I couldn't see why not, but the spec listed 16 Gb. I would not expect 64 Gb to work though. ....a step too far.

  • @jimit yes 32GB is the max partition size for FAT32, that was a lucky choice.