Cardputer COM Not Working

  • @hanktttop said in Cardputer COM Not Working:

    I didn't know about this application. I just tested it, but it doesn't connect either.


    you said that com5 is showing and vanishing when you connect to usb,
    what com port is showing when you press and hold BTN Download Mode button and then connect usb? Is it com5 too or different com number?

  • Only the same COM3 as before appears, but with the description "Paired". But you can't initiate communication. There are no other USB devices connected to the machine.


  • Have you installed both the cdc and serial driver?

  • @ajb2k3 Maybe not. Following the guide, I installed this FTDI driver. The page says that the Windows installer will install both the VCP and D2xx:

    Have I been installing the wrong driver this whole time? facepalm

  • @hanktttop Seeing that this is a "Flipper" type hacking tool...maybe it attacked you and is deauthering you.
    TV B-Gone port (thanks to MrArm's HAKRWATCH) to shut off many infrared-controlled TVs, projectors and other devices
    AppleJuice iOS Bluetooth device pairing spam
    Bluetooth device notification spamming for SwiftPair (Windows) and Android
    WiFi Spam - Funny SSIDs, WiFi Rickrolling, and a Random mode that creates hundreds of randomly-named SSIDs per minute
    WiFi NEMO Portal - A captive portal that tries to social engineer email credentials - saves usernames and passwords to SD Card (if inserted into a supported reader)
    WiFi SSID Scanner - Display 2.4 GHz SSIDs nearby, get information about them, and even clone the SSIDs in NEMO Portal

  • @teastain Yes, it is. I work in information security, so I want to install it to do some tests, nothing to attack other people. I don't believe it attacked the device, at no point was the binary executed or installed on the cardputer yet. In fact, the project is open source and you can check it here:

  • @hanktttop Hi! So it appears that Nemo is an Arduino IDE sketch that will need to be compiled, which will probably not be very fun.
    I see you having difficulty with UiFlow.
    Have you tried connecting with Arduino IDE ?
    I use 2.2.1 and it is very stable and useable with my three or four M5Stack S3 based boards, all other M5Stack products as well.
    I use a lot of StampS3s! Maybe I could help with the Arduino connection?

  • @teastain Would be great, thanks! I'm using 2.2.1, sometimes I found a "Unknown COM3" device on it that may be the cardputer (not sure yet). I was looking for a way to burn the bin with the Arduino IDE, but if I can do this by the code itself, would be nice too xD

  • After watching all the videos I was having similar issues. I ran the "hello world" screen demo through the Arduino IDE then I unplugged the machine and was stuck with the "hello world" demo. I then was unable to get the cardputer in "download mode" after trying to use the m5 burner several times. I'm on a m1 mac btw. Using a usb c <-> usb c cable. It was showing up as tty.usbmodem1101 but only when the device was turned on.

    I was trying to recreate one of the videos by trying a bunch of different orders of plugging in the wire, combinations of "on and off", holding the "go" and holding the "reset" buttons on top the device.

    I found that holding "go" would prevent auto-on when plugged in. When I did that and the pressed "reset" I think that did the trick.

    So for me it was "hold go", plug in, spam "reset", try and burn...

  • @hanktttop said in Cardputer COM Not Working:

    @teastain Would be great, thanks! I'm using 2.2.1, sometimes I found a "Unknown COM3" device on it that may be the cardputer (not sure yet). I was looking for a way to burn the bin with the Arduino IDE, but if I can do this by the code itself, would be nice too xD

    where are you from @HankTTTop ? UK by chance?

  • I've just posted a message about the boot loader/port issues in the official update forum. please give it a read.

  • @robski I'm from South America xD
    @ajb2k3 Thanks for the clarifications in the post. I'll keep trying, if I find a solution, I'll let you know.

  • @teatimer I'm sorry, I hadn't seen your comment. I also noticed that pressing the GO button makes the device not start by itself, but I tried pressing both RST and the bootload button below the sticker, without success.

    But this is progress haha, thank you.

    BTW, my notebook does not have USB-c ports, so my cables are all (Computer) USB <-> USB-c (Device)

  • @hanktttop OK. I'm wading into this discussion without having a Cardputer!
    My other ESP32-S3 and M5Stack Atom S3 and several StampS3s all work very well in my Arduino IDE environment. I also have a bunch of S3 products from a manufacturer whose name cannot be said. (coughs into hand...T-Display S3).
    So I am familiar with this S3 series on a M1 iMac.
    My iMac has two Thunderbolt ports and two USB ports. I used the USB ports just fine for M5Stack-pre-S3-models, but the S3 models wont even power up on USB, they need the Thunderbolt outputs.
    So, get to the point, teastain.
    Connection is VERY fussy and unpredictable with S3.
    All of the M5Stack S3 products that I have seen have both of the necessary buttons available. The Cardputer even has them at the front(!) no need to remove the S3 or peel back the sticker on Cardputer. (in fact DO NOT remove the S3 with Cardputer!)
    The GO button is actually GPIO 0 and is called 'boot'.
    The 'rst' button is otherwise called 'EN' which cuts power to the core when pushed and resets when released.
    Method 1 unplug the Cardputer from the USB, press and hold G0 (on the left side of the Cardputer, plug back in and release G0.
    Method 2 while plugged in press and hold G0, press 'rst' on the right side, release 'rst', then release G0.
    In both cases if your sketch does not boot up and run, it is recommended to unplug it and plug it back in to boot.

  • Hi @teastain Thanks for clarifying the buttons.

    I tried both methods, neither worked. As @ajb2k3 said in his other post, maybe S3 was blocked. The curious thing is that I'm having the problem without even being able to install the firmware. I tried to burn it minutes after receiving the device via AliExpress, I didn't complete a single firmware change.

    That's why I suspect the drivers more than the device. I reinstalled all of them again, also tried on another Linux (Ubuntu 22.04.3 LTS), no results so far.

  • @hanktttop Do you have any other Arduino or ESP32 that will work with your computer?
    Do you only have linux machines?
    This is probably not an M5Stack issue, maybe reach out to the linux community for installing Python drivers.
    Also Adam's point Nemo is based on Flipper/Marauder !
    The bootloader is indestructible and still present, buried safely deep in ROM.
    When you received your Cardputer did it power up and run the Demo?
    What does it do on power up now, today.

  • @teastain I have a Windows 11 and a Linux machine with Ubuntu (a few days ago I tested using Fedora). Cardputer works with the demo. It's the firmware it arrived with and the same one that runs normally when I turn it on currently.

    I have some arduinos, Uno, Nano, Lilypad, a LoRa module, all these devices are working normally, they are recognized without problems. Right now I'm using a multimeter to check if any S3 pins have problems (I'm not that experienced with hardware), but they all seem ok. I even think that even the demo wouldn't work if there were problems with them.

  • I only have windows 7 (yeh old) but it would appear that the issue is how windows is handling the Chinese drivers ie, if the driver wasn't made by Microsoft, windows is trying to block the driver.

  • @hanktttop can you help me ? mycardputer not turning on

  • @twinturbo said in Cardputer COM Not Working:

    @hanktttop can you help me ? mycardputer not turning on

    Have you charge it and tried the power switch?