M5Stack Fire dead and getting hot after testing Steppermodule and Servomodule together

  • Good Morning,
    Yesterday I got a nice package from m5 with my awaited Stepper and Servo modules which I need both for a project.
    My first test was the Stepper-Module (with original power adapter) on a Fire and the provided test sketch.
    It worked perfectly.
    My Second Test was adding the Servo module as well and i combined Stepper and Servo test sketch.
    It worked as well.

    After combining the two sketches ,stacking Stepper and Servo board and connecting power nothing happened.
    While disconnecting and disassembling again to check what could have gone wrong i burned my thumb on the really hot esp32 cover.
    So obviously something has gone terribly wrong.
    It seems that the fire is dead now and if i connect it to usb it gets hot again and does not do anything.

    Probably somebody from m5 can check this - i don't want anybody else to have the same issue with a killed M5 Fire

    Cheers Chris

  • Did you try running them without the external power supply?
    Sound like it’s cooked!

  • It's definitely cooked :D I just do not understand what happened and don't want anybody to have a dead esp as well :D

  • @mrtarantl
    Did you use the cooling fan module as well?
    I glad you let us know what happened and sorry to hear about this mishap.

  • @ajb2k3 yes I did use the cooling module as well.
    My thought was that there probably is some electrical interference when using the stepper and the servo module together. My solution in that case will be that i disconnect the mbus from the voltage regulator +wire completely to only power the steppers with the external power supply and do the rest with usb power to the m5Stack, so i am safe :D