Installing Linux on CoreS3

  • I still can't use M5Burner from work - as it defaults to some odd web browser extension that is banned. (I get a popup saying that the web browser it tried to use was banned) So I am unable to login with it. (login always fails)

    (Edit: It is banned -at my work-, not banned in general. I want to make it clear it isnt malware or something - just not approved by my employer)

    I can burn UIFlow2 images from the Web-burner option from UIFlow2, but I am limited to.. well, UIFlow2 images obviously.

    Im very excited to try the new Linux image for the CoreS3, but would need to be able to access the .bin separately from M5Burner, and load it manually via Uiflow2 Web-burner, which I think is possible.

    Is there a way I can get the binay image directly?


    Edit: Oh - I may have misunderstood that option in web burner - it looks like it is export firmware images toa file only - not burn them manually from a file to the device..
    So - is there a way to do that outside of M5Burner?

  • Well - I couldn't get it done at work (after work hours) but when I got home, I was able to get my CoreS3 to load and boot linux. This is so cool!

    0_1689066441616_cores3 linux ss2.png

  • What can it do ?

  • Wow what linux version did you use?

  • @ajb2k3 Well... I don't know, lol.

    I saw the tweet about it from IAMLIUBO, and then saw the FW release in m5burner, and just wanted to try it.

    But so far, it looks like a "proof of concept" - a starting point - no drivers for the LCD - not sure what else is supported, just a serial connection to the UART and a filesystem so far? Im not a linux expert.

    I did see some notes from the developer or developers ( rudi ;-)@eMbeddedHome - ) about going for implementing native wifi next - and it looks like he got that working about.... well sometime in the last few hours (minutes?) sheets/

    He sounds like he is coding between breaks in some long party he is having!

  • Have tried to burn the CoreS3 Linux Port with the M5Burner.
    But there is no output on the uart0, nor on the USB-C virtual com port.
    Also nothing on the screen.

    How did you make it ?