help needed to get started.

  • how to get started?
    I received yesterday my m5 atoms3- but when I look at the uiflow2 ( bwebbased version. I cannot add a device ....
    I would like to use it but no way.. what I am doing wrong?
    Uiflow redirect me tothe shop.. So I cannot add a private owned M5 stack core I have.... please help... all tutorial start after this can you provide expertise!

    thk u in advance

  • You need to download M5Burner, put the AtomS3 into boot loader and plug into computer. The registration system works differently with the S3 generation products in that the device is bound to your account during flashing

  • Hi ajb2k3! thk for getting th time to answer a newbee...I installed M5 burn and logged in with my account... and the driver 210 for my windows machine....I tried to install Uiflow2 firmware on it by clicking burning... but M5 is blocked in a the moment...

  • By the way the small led screen with a button behind seems to be relatively fragile...I pressed it to change the mode to play with imu... and now the screen seems not fully operational...

  • I see an uncaught exception eperm acces not permitted... I was not knowing what to do and as windows see the sofzware as a threat...

  • a javascript error has occured

  • 0_1684953474750_javascript error m5.png

  • @DR_Froggy_rD It says you to open the file from the address shown.

  • @matejtech said in help needed to get started.:

    you to open the file from the address shown.

    thk you for your point

    ok but the file tmp is empty.

  • has someone also problem by starting with their M5 stack dev board???

  • We have 1 of two issues here.

    Issue one (most likely) you haven't put the Atom S3 into Boot mode and so M5Burner cant access the AtomS3's eprom


    Issue two Windows built in security is blocking M5 Burner from writing to the EPROM.

    I have a video for the CoreS3 going live on Saturday which shows how I flashed the CoreS3 using M5Burner (or at least I hope I didn't cut that bit) but the instructions still work for the Atom S3

  • I got the way around the problem of security but still the tmp file is empty so it cannot access the patch because there are no files there

  • I was able to run the m5 burner as admin ( right click on the icone m5).... so this must go through the windows issue although the file is empty.this still be an issue.

  • the zip file is not inside the folder.....

  • Why is it looking in the pictures folder?
    M5Burner should be in the root user folder or the programs folder!

  • Because it put the downloaded zipfile in here and extracted here...

  • As it is not a msi installer but just an exe i had never a problem running an exe not from the program files folder. Also from the temp folder.
    It is not playing a role sofar. This would be for me the first time.... if this is mandatory one must write a step by step standard procedure as idiot proof as possible...
    Nevertheless i an sure trying to extract into the program file folder will not solve the missing patch honest opinion.

  • Hi adam, I saw your review of cores3, sad that this part is not as straight foreward as one can expect.if i reckon correctly you struggled to get uiflow burned to the device as well. I did not get gow you did it!
    But you erase first the mwmory using m5 burner.

    The boot load mode was quite tricky to trigger.seems like
    On the atom s3 i need to press the side button for 3 seconds and a green led is shining for 2 secs i however do not know if you started thw mode. It stays in this mode untill you power off.

  • @dr_froggy_rd

    No it doesn't start in this mode. Thank you for watching the video.

    The second time it work fine.
    Connect to computer,
    Press and hold boot button for a few minuets and "Port ***** detected" will show,
    Click erase and wait,
    click write and wait,
    power down and rest the S3 device and UIFlow starts.

  • Hi Adam, so: I unzip my file in programm subfolder.
    open M5nurner .exe as administrator.I can update firmware list.... but still looking for the same patch in the unzipped folder: I have anotherjavascript error message:: It is not EPERM but ENOENT..
    However I connected the s3 to it. and push the left side button until green led flashes....then connect com6 (the detected port com there it is green) It fails to erase or to burn. failed to get mac. also when reducing the baud rate to 11000..
    I tried even the easyloader software without success...