Fire is dead ... how can this be solved ?

  • Hello
    I have received my new M5Stack Fire.
    On the Arduino IDE, I load one of the Examples (M5Stack Fire) > ESP32> Time> SimpleTime.
    I compiled the SimpleTime to be displayed on the screen
    The compile was fine done., load them up via the USB into the M5STack Fire. ...since them nothing happened.
    Display is black start is possible nothing is working any more :-(
    I tried then to load the UIFlow-Desktop-IDE no connection via COM3.
    Since then the RED LED is just on :-( no Python Menu is comming up just nothing
    My question is how get I back my M5Stack Fire working?
    Does the Hard RESET may be solve my "dead M5Stack Fire" ?
    Thanks a lot for your assistance

  • Have you tried using M5 Burner to erase and re write the firmware?

  • try to use m5 burner, then erase or load new firmware thru it, i do have one core unit which suddenly stopped to display anything on lcd screen, i can connect to it, load projects but nothing is showing up on screen except backlight is on.

  • Hi I have the same issue and get this error when I try to upload
    Sketch uses 404741 bytes (6%) of program storage space. Maximum is 6553600 bytes.
    Global variables use 23136 bytes (0%) of dynamic memory, leaving 4498848 bytes for local variables. Maximum is 4521984 bytes.
    "C:\Users\myles\AppData\Local\Arduino15\packages\m5stack\tools\esptool_py\4.5.1/esptool.exe" --chip esp32 --port "COM23" --baud 1500000 --before default_reset --after hard_reset write_flash -z --flash_mode dio --flash_freq 80m --flash_size 16MB 0x1000 "C:\Users\myles\AppData\Local\Temp\arduino\sketches\90AA1942EA0BA4EF7597B8CEDA18AD54/nextgen.ino.bootloader.bin" 0x8000 "C:\Users\myles\AppData\Local\Temp\arduino\sketches\90AA1942EA0BA4EF7597B8CEDA18AD54/nextgen.ino.partitions.bin" 0xe000 "C:\Users\myles\AppData\Local\Arduino15\packages\m5stack\hardware\esp32\2.1.1/tools/partitions/boot_app0.bin" 0x10000 "C:\Users\myles\AppData\Local\Temp\arduino\sketches\90AA1942EA0BA4EF7597B8CEDA18AD54/nextgen.ino.bin" v4.5.1
    Serial port COM23

    A fatal error occurred: Failed to connect to ESP32: No serial data received.
    For troubleshooting steps visit:
    Failed uploading: uploading error: exit status 2

  • You have installed the esp32 libraries and board definitions along with espidf?
    Have you selected the correct board type and communication speed have you made sure the example was actually for the fire and not another core?

    Have you erased the core using M5Burner first?
    Have you watched or read any of my guides or the many other guides on programming a core?

    I found the solution:
    You need to follow these steps

    1. Remove all modules, leaving only the host
    2. Then try to lower the baud rate when burning
    3. If there are wires, you can short-circuit G0-GND before powering on the device and then power on again.0_1711007605157_432299571_430472252787300_1867478767739245481_n.jpg