Unable to load new FW from Arduino IDE.

  • I had no trouble with previous devices from CORE2 (2 test units), I did order 20 units to proceed, but none of them work.
    I have donde even a very simple Arduino Program with no luck, also tried my original program that is working with the 2 initial units

    It thorws this exception:

    ERROR A stack overflow in task IDLE1 has been detected.
    abort() was called at PC 0x40088bfc on core 1

    //#include <M5Core2.h>
    //#include <M5Unified.h>
    void setup() {
    void loop() {

    ELF file SHA256: 0000000000000000
    Backtrace: 0x40088974:0x3ffba560 0x40088be5:0x3ffba580 0x40088bfc:0x3ffba5a0 0x4008a4de:0x3ffba5c0 0x4008be74:0x3ffba5e0 0x4008be2a:0xa5a5a5a5

  • @fbritop I would put a delay(100); in the Loop:
    You can get a race condition where the scan time is shorter than the esptool reaction and it could be "too busy" to stop and upload.
    If this is the case it will take some finagling to reset the upload mode.
    Usually just pressing the reset key on the top side, at different times until you get in time.

  • @teastain This is not the problem. I have tried with the original code that is working on other 2 units and does not work also.

  • @teastain This is en backtrace decoded:

    PC: 0x04d25826
    EXCVADDR: 0x04d25824

    Decoding stack results
    0x40090d71: prvIdleTask at /home/runner/work/esp32-arduino-lib-builder/esp32-arduino-lib-builder/esp-idf/components/freertos/tasks.c line 3382
    0x4008f5b6: vPortTaskWrapper at /home/runner/work/esp32-arduino-lib-builder/esp32-arduino-lib-builder/esp-idf/components/freertos/port.c line 143