Servo Kit 180 connection

  • Hi,

    I'm trying to connect a Servo Kit 180 to a M5StickC. However when I try the Stick shuts down when I connect the red pin.
    See images below.
    Do I need a separate connector or are the pins mixed up.

    alt text
    alt text

  • @kylebuttress If you will notice that under your thumb there are three "Hat" can plug the servo directly, pin for pin, into this and set the LEDC or other servo library to output #26. Try this as a test!

  • @teastain OK, I tried to check this out and something is very wrong.
    Please wait while I investigate!
    Mine crashes too!

  • @teastain Thanks, I tried what you mentioned and same shut down...


  • @kylebuttress Well, what an evening!
    Does your battery work? Will it boot on battery only?
    Some of my newer StickCPlus units will run the servo. One has a very good battery and will run the servo without USB! One will run the servo on USB but not battery only, one ( the one I tried 3 hours ago) will do exactly as yours. No way will it run the servo.
    So I think this is my answer!
    Cheers, Terry

  • @teastain Thanks for the info. I hope you got something out of this adventure :). The StickC does not have a battery. I'll try with the Core Grey I have, it has a battery and see I can get it to work with the pins and not the Grove.

    It does seem odd though.

    thanks again

    cheers Kyle

  • Does the Stick power up with the servo connected?
    You're not supposed to connect anything with the controller powered up, you are supposed to only connect things when the controller is powered off.

  • @ajb2k3 My StickCPlus with the dead battery will not boot with the servo attached, and, will crash if you add it while running!
    Are replacement batteries available do you know? EDIT> it is a common battery with many sources > Otherwise I will try installing a large cap in the battery are that is charged by the USB, not controlled by the AXP power chip.
    StickCPlus comes apart very easily, but cut the hat I/O decal to slide it out.

  • @ajb2k3 When the servo is attached and then plugged in, it does not start. When the servo is removed and then plugged in it starts..

  • Mine is booting fine once the battery is charged without the servo connected.

  • I have been able to get it working with the correct wiring using the grove port in a Core Basic Gray unit.

    No I will start to use the io pins in the bottom of the unit so I can use the grove port for other things.

    thanks for all your assistance.