Having almost no luck working with the M5Stack Core2 in Fedora Linux

  • Pardon me for the "needy" question - I'm out of ideas.

    I am able to connect/load/run simple c code using Arduino IDE.
    I can find the device as /dev/ttyACM0
    I can connect with screen /dev/ttyACM0 115200 and run short Python commands.

    However, I cannot get the UIFlow GUI (offline or online), or Visual Studio Code (with micropython extension) to ever find the device. I get tossed errors on the PC like "Upload code failed, maybe your device is offline" etc. Or the type shown on the M5 reported in https://community.m5stack.com/topic/4904/m5stack-programming-with-visual-studio-code-in-linux .
    I tried WiFi connectivity to no avail - I get to the part where I enter the IP address in the browser, I enter my home WiFI Password and it fails.

    I've tried numerous "getting started" videos, but they either don't cover the Core 2, or they don't cover Linux and otherwise just don't help.

    My preferred development environment is VSC, USB connected, micropython (maybe c).

    Any help would be appreciated.