ATOMS3 code load failure

  • Trying to load arduino code for the first time from IDE. Updated all my library files. Fails with the following:
    WARNING: This chip doesn't appear to be a ESP32 (date codes 0x03700000:0x00000000). Probably it is unsupported by this version of esptool.
    Chip is ESP32-D0WDQ6 (revision 0)
    Features: WiFi, BT, Dual Core, Coding Scheme None
    WARNING: Detected crystal freq 0.00MHz is quite different to normalized freq 26MHz. Unsupported crystal in use?
    Crystal is 26MHz
    MAC: 00:00:00:00:00:00
    Uploading stub...
    Running stub...

    A fatal error occurred: Invalid head of packet (0x47)
    A fatal error occurred: Invalid head of packet (0x47)

    An error occurred while uploading the sketch

    I did hold down the reset button until the light turned green.

  • @dheco Well, I have one on I cannot yet try the Arduino IDE, but the chip is actually
    ESP32-S3FN8, not ESP32-D0WDQ6 as the esptool reported.
    So, hopefully someone in this community will tell us which Board to select.
    (AtomS3 is not yet listed in the Board Selection menu)

  • Did you update ESPtool?

  • @ajb2k3 Yes, I am running the latest 1.0.4.

  • There was a reply from M5Stack about this on Twitter.
    Apparently support is delayed because the programmer behind it is off sick at the moment.

  • Looks like I need to use M5unified also?

  • It's not that simple because the ESP32 S3 is not the same as the current chips used in M5Stack products.

  • Went thru and tried to convert to M5unified, now IMU and SD code does not compile..
    error: 'SD' was not declared in this scope
    error: 'class m5::M5Unified' has no member named 'IMU'

  • Looks like updates dropping regularly, the M5 board file latest update 2.0.6 may add some support but broke other code so I am sitting at 2.0.5 right now. Could not get unified to work because of errors with IMU and GFX issues so I stopped trying that for now. Will test again next week.

  • OK, I just had the same problem and .... is amazing, but the manufacturer Heltec has their libraries on this pcb wrong or at least obsolete. When you put as PCB a "Wireless stick lite" trying to program, but its version is the latest (v3) with an ESP32S3, it shows an error message. Solution, use the expressif PCB library instead of the Haltec library and select the correct board and the problem will be solved.