RTC UI Flow - GET RTC doesn't work

  • Hi,
    I am struggling with RTC module M5Unit-RTC: https://docs.m5stack.com/en/unit/rtc

    I know it's working, and powered on, because it responds correctly to alarm, and timer commands.

    However when I try to use the GET RTC (seconds) command it fails.
    I tried everything: changing it to int(), assigning a variable with the get_rtc() - nothing helps

    I am attaching an example.

    The behavior is as follows:

    • LED turns to yellow (inicialized)
      after 3 sec LED turns to Blue (the date and time is set)
      Instead of going to green the LED goes to <red> the moment a line with get_rtc command is being run.
      It's always the same with every other things I try. The moment I use this block the LED turns red and stops working.

    I am looking forward to hearing your thoughts

  • Hello @mickud

    • which device (M5AtomLite, M5AtomMatrix, M5Stamp, ...) are you using?
    • what UIFlow firmware is running on your device?

    I've tried with an M5AtomLite and M5StampPico (both UIFlow firmware version 1.11.0) and using get_rtc command works just fine for me.

    BTW: convert to int seem to be unnecessary.


  • Hi,
    I am using Atom Lite. It's the one from ATOM Stepper Motor Driver Development Kit (DRV8825)
    I am using UIFLOW(LITE) v1.9.8 downloaded using the Burning Tool

    I checked if the Burnning Tool would update the UIFLOW version, but I did not download the newest Burning Tool version. That must have been a mistake.

    Now I downloaded the newest Burning Tool with UIFLOW 1.11.0 on board and it is working correctly.
    Thank you Felix. Much appreciated!