Saving programs from UI Flow Web

  • I can connecr my M5Stack Fire and CoreInk to the web Ui Flow app and upload Blockly programs to the devices and run those programs on the devices. What I cannot do is save those programs to use again another day. Clicking on the "Save" or "Save as" does absolutely nothing. How can I save the apps I develop using blockly on the UI Flow Web app?

  • @steve1 have you typed a file name in first?

  • I have given it a name in the bo top-right where the default is "Main" but I think you must mean something else. Would you be so kind as to walk me through building a program using Blockly and then saving it where I can reload it for further work another day.

    I am more used to programming with the Arduino IDE and the UI-Flow web app does not seem intuative to me

  • For me it works fine when click on the "Floppy". It saves a file with the name given in the project name (even if it is called "main") and use .m5f extension. You will find the file in the browsers downloads directory. It is possible to load this file later oder view the content in any text editor.

  • @holofloh Clicking on the Floppy doesn't do anything in my setup, no downloads to the downloads directory. By the way I am using Chrome under Ubuntu Linux.

  • @steve1 I have just tried the UI Flow web application in Firefox (I was using Chrome up until now) and I can save my work by clicking on the "Floppy" icon. So it seems this is a Chrome problem.

  • What version of chrome are you using and have you checked chromes security and permissions tabs?

  • @ajb2k3 I am using Chrome version 106.0.5249.103, the latest version for my Ubuntu 22.0 OS. Maybe this is off topic but what Security and permissions tabs do I need to check to allow a website to read and write to my harddrive? I have tried adding "--allow-file-access-from-files" when launching google-chrome from the terminal, but that didn't work.

  • Have you tried resetting Chrome, Sorry I haven't worked with Linux for years and chrome has been working fine for me.

  • I have the exact problem: Chrome 107.0.5304.110 on Fedora 35. All buttons in the UI (label, button, line, etc) are nonfunctional as well as the "load", "save" etc buttons. UIFlow is completely unusable with Chrome. I can reproduce this in Konqueror also.

    The buttons seem to work in Firefox though.