Cannot use UIFlow with Atom Lite

  • I used M5Burner to write UIFlow_Lite v1.9.6 for the ATOM Lite to my device. It has sucessfully connected to my WiFi, and I have provided the API key on UIFlow.

    When clicking Run in UIFlow, it connects to the device, and the COM Monitor on the device spits this out:

    Traceback (most recent call last):
      File "flow/", line 105, in _exec_data
      File "<string>", line 8, in <module>
    NameError: name '__VERSION__' isn't defined

    I have tried different versions of the firmware but they all produce this result. I have only just got my device, so I haven't got UIFlow to work at all yet.

  • Hello @ahorner

    works for me here. Tried with firmware 1.9.6 and 1.7.5. I do not get this error.

    Could you share the actual code you tried to run? Have you tried to erase and re-burn the firmware? (Please note: if you do, the API key will change.)


  • @felmue Hi Felix,

    A full erase and reburn, with a change of API key, has corrected the problem. Doh! How did I not already try this?!?!

    Many thanks,


  • Hello @ahorner

    thank you for reporting back. I am glad to hear you've got it working.


  • @felmue Hi Felix

    Unfortunately, I am back,

    It appears if I reset or unplug and plug back in (effective reset) the device, the issue comes back.

    The device will only work after an erase, burn and connect to UIFlow. Once connected, I can run as much as I like. Any disconnect appears to "kill" the device with the aformentioned python error on the COM Monitor until I do another erase, burn and connect etc,



  • Hello @ahorner

    I am sorry to hear. Very strange indeed. Unfortunately I cannot reproduce this issue. Maybe somebody else has an idea about what might be going on?


  • Bump on this one, anyone know what might be going on? Thanks!

  • @ahorner IIRC I received this error on an M5StickC Plus when the firmware version and UIFlow version did not match.

  • @wsanders Hi there, I am using the latest firmware with the latest UIFlow

  • I've been experiencing a similar issue with two recently purchased ATOM Lite devices. However I couldn't even connect at all with UI flow on version 1.9.5.

    I've been using the vscode extension as I find it to work butter than using UI Flow Desktop and Web. But still need to flash the device constantly.

    Although I can successfully download and run the code, I can't get it to run in App mode, I suspect the OP might have the same problem.

  • @slavs Hi there, to you and to everyone:

    I contacted M5Stack support and have received a reply. This issue is a known firmware bug with the ATOM Lite.

    They said:

    Hi Alex,
    Yes. We confirmed that's a bug. We will fix it in recently version.
    Currently now, you can click 'reflash' button before downloading the firmware, which should work.

  • @ahorner thanks for letting know!

  • It appears this bug is fixed, not in the firmware, but in the latest version of UIFlow!