PlatformIO and Tasmota

  • Hello,

    Tried to burn Tasmota to my Core2 (AWS?) with both Tasmotizer and ESP flash. The furthest I got was it says that it was successful, but the device fails to boot (just sits there with a black screen). I did use the correct tasmota-core2.bin image.

    I then tried to use PlatformIO by selecting M5Stack-Core2 for the board and Arduino as the platform. It too uploads, but the device still doesn't boot.

    I also followed the steps laid out in this post:

    But still no luck - it fails to compile with the error "collect2.exe: error: ld returned 1 exit status *** [.pio\build\m5stack-core2\firmware.elf] Error 1."

    I can use the M5Burner application though, and it does burn new images to the device.

    Can anyone point me in the right direction to get PlatformIO and/or Tasmota working on this device?

  • Hello @Slyke

    Tasmonizer did not work for me either. VSC/PlatformIO only worked with version 9.5.0. (Version 9.6.0 or master don't compile for me.)
    Here are the steps:

    • Clone Tasmota: git clone
    • Checkout 9.5.0: git checkout pre-release-9.5.0
    • Rename sample file: mv platformio_override_sample.ini platformio_override.ini
    • Open project in VSC/PlatformIO
    • Modify platformio_override.ini: comment out: tasmota / uncomment: tasmota32-core2
    • Compile & Link & Download from within VSC/PlatformIO

    Note: there is nothing on the LCD screen at this point. I think the device is waiting to be configured.

    Serial output:

    00:00:00.001 HDW: ESP32-D0WDQ6-V3
    00:00:00.011 UFS: FlashFS mounted with 10292 kB free
    00:00:00.031 CFG: Loaded from File, Count 5
    00:00:00.036 QPC: Count 2
    00:00:00.038 SPI: Hardware using GPIO18(CLK), GPIO23(MOSI) and GPIO38(MISO)
    00:00:00.248 I2C: AXP192 found at 0x34
    00:00:00.250 I2C: RTC found at 0x51
    00:00:00.257 BRY: Berry initialized, RAM used=1760
    00:00:00.261 BRY: no ''
    00:00:00.837 I2C: FT5206 found at 0x38
    00:00:00.837 DSP: ILI9341
    00:00:01.409 Project tasmota Tasmota Version 9.5.0(core2)-1_0_6(2021-10-21T09:48:12)
    00:00:01.409 UFILESYSTEM OK!
    00:00:01.515 CR2: Set time from BM8563 to RTC (UTC) 2000-02-04T13:00:32, (DST) 1970-03-29T02:00:00, (STD) 1970-10-25T03:00:00
    00:00:01.521 BRY: no ''
    00:00:01.818 WIF: WifiManager active for 3 minutes
    13:00:33.537 HTP: Web server active on tasmota_C50340-0832 with IP address
    13:00:39.532 QPC: Reset