Downloading updates - fails

  • The download speed from M5Stack has dramatically worsened in the past two weeks. While I can still download firmware to core devices like Fire and Core 2 it often fails in the first attempt and it can take up to three attempts to get the download. It is now impossible to install Board Manager drivers under the Arduino IDE for M5Stack processors. I tried ten times and it failed 10 times - for example the 45MB M5Stack board Manager files only reached 10MB and refused to continue. I have excellent internet speeds and have no problems in downloading from elsewhere. I repeated the download and update procedures on another Windows 10 computer and had the same problems. On starting the Arduino IDE it attempts to update the M5Stack board file and gives me the error: Error downloading
    Is this a result of the recent UIFlow updated to 1.6.6? Software quality at and download speeds from M5Stack are terrible! This brings into question the whole viability of M5Stack - good hardware but shocking software support.

  • Hello, may I know your location (country)? We would like to perform server CDN test and see if there are any issues with certain countries to connect to our servers.

    You mentioned there is an error, could you please explain the steps for re-production and post the output you are getting?

  • I live in Italy and in the weekends I keep experiencing several issues:

    • Many times when I push the program run (the triangle icon) in UIFlow fails. It just say that it can't connect to the device although the device shows that it's connected
    • When the device boots sometimes it takes up to 15 second to connect to UIFow cluod service
    • Downloading the program (the arrow down in the folder icon) is a lottery. It keeps saying something like "Timeout loading"

    My internet connection is reliable and I don't experience any issue or delay with other internet services.

  • @dario Hi Dario, last night we moved some API's to our CDN which wasn't configured on the CDN before, we hope it can solve the issue. we did a global server speed check - everything seems to be normal at the moment.

    We are sorry for the inconvenience it might have caused to you.

  • @zontex I am in Australia. I also had problems with downloads yesterday - extremely slow download speeds and often downloading just hung. Occasionally core firmware downloads would get accepted by M5Burner after 10 attempts but drivers for the latest M5Stack cores could not be updated from the Arduino IDE using the Board Manager with a reference to 'M5Stack'. At the end of attempting downloads if it got that far it produced a CRC error and the Arduino IDE abandoned it.

    Today everything changed - downloads were fast, only one CRC error but a second download was successful. On a second Windows PC the first download was successful. I now have the latest drivers on my Arduino IDE for all M5Stack Cores and I have the latest firmware versions. I could develop test software for Fire, Core 2 and Core Ink using UIFlow IDE on Windows and downloaded onto all of these platforms but I was only able to execute code - Fire. While Core Ink accepted my firmware it would not execute it. Both Core Ink and Core 2 are hard to control compared to Fire and I could only get my firmware to download and execute on Fire.

    I suggest that M5Stack do more alpha testing with users from a few countries before officially announcing a new version. This is a regular issue with M5Stack and happens after each new version is released. While these failures were occurring I could not do any software development on M5Stack from Arduino IDE to UIFlow.

  • Hi @dsrc12 Thank you for your very detailed feedback, we've done few changes on our server side configuration so now the download speed should be solved. regarding some other connections issues with M5Stack devices, we are looking into it and we definitely will put more care into the testing process before release, we really appreciate the feedback as it helps us to help you guys get better experience using our products.

  • @zontex
    I have issues with downloading even today - 11 Jan 2023! not able to download boards and I just bought Core2 for close to 60USD - I have not been able to get it with Arduino - please assist ASAP.

  • Rhe problem is the main server is/was behind the Great Firewall of China and so with more and more uses trying to access the server, the more often the server will crash