Online UiFlow version on mobile browsers - dissapearing virtual keyboard

  • Hello.

    I noticed some inconvenience in the online uiflow version in mobile browsers. The problem started to appear around the time when firmware 1.4.x and higher were released. The problem concerns the pop-up dialog boxes in which the text should be entered. e.g. settings: apikey, create new variable. The problem occurs in Android 7 and 8 (I have not had the opportunity to check on others). It makes no difference what browser I run uiflow on, be it chrome, mozilla, edge and similar. No matter if older or newest versions. The problem manifests itself after opening a given dialog box and after touching a given field for editing (apikey, variable name) a cursor appears, a virtual keyboard appears and immediately disappears (touchpal, google, hacker's keyboard), which makes it impossible to enter any data. Even connecting a physical keyboard does not help: after tapping in the field, it will be possible to enter at most one character. In the edit field of the name of a new variable the only thing you can touch and hold and paste some text from the clipboard. Interestingly, this problem does not apply to block dialogs, e.g. string editing where text can be entered without any problems.

  • Hi Robal, could you please help me clarify if you are having the same issue with both version 1.4.5 and the beta version or just the 1.4.5 version? meanwhile I will try to replicate the issue you are having on others devices and see what I get.

    Edit: I've tried on Android 10 and can confirm the issue does exist, will dive deeper to see how to get it fixed and get back to you.

  • @zontex On the 1.6.5 beta version i noticed the same behaviour. (also on the two other brand smartphones). I think it was normal until version 1.3.2-1.3.5.

  • @robalstona said in Online UiFlow version on mobile browsers - dissapearing virtual keyboard:

    it was normal until version 1.3.2-1.3.5.

    Hi Robal, I've opened a ticket and I'm on it to figure out why it's happening. thanks for giving this feedback and letting us know, I'll get back to you later with results.

  • @zontex UIFlow 1.7.4, the bug still not fixed. This makes UIFlow completely unusable on mobile browsers.