ERROR Invalid syntax (UIFlow 1.6.2) when trying to upload

  • When I try to upload my project i get this error:
    X ERROR Invalid syntax
    Detail: File '<string>', line1 Syntaxerror: invalid syntax (quite explanatory, isn't it :)

    My project runs fine from UIFlow and It does upload the python file, I can select and run it from the core

    I've been searching around here but only found this post but it did not provide a solution.

    Could this be a bug or is my project messed up or something else ?

    UIFLow version 1.0.11 FW1.6.2 on win10 64

  • Nice project.

    Are you using the offline/Desktop version of uiFlow? If so, can you try the web IDE to see if you get the same error?

  • @world101
    Hi and thanks,

    Indeed I use (and prefer to use) the desktop version, but I gave it a go with the online version. A similar thing occurs, I can run it, but now it hangs when trying to upload to the device, showing the "Uploading..." indicator on the core screen...

  • It’s usually quick, but sometimes downloading your flow to the device takes a bit (~1 minute). Send or PM me a link to the file and I’ll give it a try.

  • Also, the Desktop uiFlow IDE is several revs behind the web version. I hope they will keep both IDEs in feature parity in the future.

  • @world101

    Hi, I left it "uploading" for about 15mins, long enough to conclude it hangs I suppose.

    You can find the m5f file here
    (Bear in mind, I'm no coder, just a hobbyist)

  • Download (or upload to the device) worked for me. However, it took several tries for my device to stay connected to the uiFlow web IDE. I kept having to hit the refresh button and I rebooted my m5stack once.

    Stability of the web IDE can vary, depending on your location, time of day, and how many people are using the server. But overall, I didn't have a problem with our flow and it loaded onto the device in about 10-15 seconds.

    If you still can't get it, you could switch to the Python tab and copy all the Python code to a file called on your computer. Then use ampy, Thonny, Mu, or another utility to copy to your device and place it in the /flash directory. Then the m5stack should boot your program by default after startup.

  • @world101
    Hi, thanks for having a go at it.

    As I mentioned before, with the desktop version the python file gets uploaded, but then I get the syntax error (when it should auto-start after the upload). After a manual reset and switch to app mode, the python file is on the device, I can select and run it on the core, it runs fine. I can run the py from and upload it via Thonny too without any problem. I've tried it on 2 devices, a black and a grey, I've tried different cables all with the same result.

    With other projects the upload to the device also works fine. Is it because there something wrong with my .m5f ? Is it because its a little bigger, who can tell ? I really would like to have this issue solved before I officially share this project so people -especially new to m5stack- can atleast get it up and running without hassle.

  • Wel this problem still persists, I guess I was secretly hoping for someone from m5stack to shed a light on this matter. ;-)
    Is there maybe someone who could try to reproduce this error with the desktop version of UIFlow ?

  • So I managed to get UIFlow running on a linux machine (a struggle in itself, I dare say) and... same result, it hangs while uploading via USB. It doesn't give me the syntax error, but it's stuck with the "Uploading..." indicator diplayed on the device.

  • @ardo thank you feedback. i had test your program (m5f file) , got the same stuation in the offline version UIFlow 。 (the online version UIFlow is not problem. ) we will fix this bug as soon as possible.

  • @m5stack

    FW1.6.4 and editor 1.0.12 totally broke my program, still can't upload but then again, why would I need to, it doesn't even run anymore, the python code gets screwed up.

    I don't get to make an app anymore, all I do is running into stuff that doesn't work. It seems to me M5stack is suffering from what I call the "Yamaha disease" : keep spitting out new hardware without fixing the mediocre stuff they released before.
    Well I for one am not jumping on that train anymore , I refrain from buying any more new stuff a la core2 and whatnot before the existing stuff gets fixed. (which I expect now, will never happen)