EXTEND IO Unit - is anyone successfully using this unit? If so, please help!

  • Hi,
    I have now unsuccessfully tried 3 different Extend IO units (2 arrived today from different suppliers) on 3 different M5Stacks (Fire and Gray). I have also tried the units via a Pa.Hub but they still give an error.
    Other units, eg Temp, PIR have worked OK.

    It would be great to know if anyone is successfully using these units before I spend more time on this method of getting more IO onto the M5Stack.

    I have used Blockly V1.5.4 and 1.4.5 to write simple test routines.

    Errors on M5Stack display:

    local variable referenced before assignment"


    "Unit: Ext IO unit may not be connected"

    Any help or advice would be welcomed.

  • UIFlow only support M5Stack brand EXT.IO Unit. for other brand ,if you want to use they in the UIFlow. you need check they has same pins and chip etc.

  • Thank you for the above comments.

    I am using the official M5Stack but bought from different suppliers from here in the UK.

    I have now tested the 3 units successfully by accessing them directly via the I2C bus address and registers rather than the UIFlow Unit ExtIO libraries. I can read and write to the IO using this method so I suspect there is a bug in one of the UIFlow library routines. I have raised this with M5Stack and I believe they are looking into it.

    It would still be great to know how others are using and accessing the ExtIO Unit especially using it via the Pa.Hub. Thank you again.