How to get UI Flow on to device?

  • I've been using a kit that I purchased from I've been programming with Arduino, but would like to use UI Flow. All of the tutorials show that UI Flow should show on booting up- but I haven't seen this. There are videos on how to get to "wifi" or "settings" on your device, but mine doesn't do this. I've tried using the Desktop app of UI Flow and tried to use the firmware burner tool, but whenever I try to click the download button, nothing happens, maybe my device is not connected.

    I can't find any tutorials on how to get UI flow working on the device without it coming with it already have the software.. any suggestions?


  • When I boot up my m5stack (just got mine a few days ago), it really briefly shows a startup splash. In the splash screen an UIFlow icon and an option per button is shown. In this brief moment I have to press the third button quite fast and select usb connection (my WIFI connection does not yet work).

  • @sjako Thanks for the reply! I don't get the UI Flow splash screen on start up.

  • I don't know if this helps you, but I think there was an update to the M5Flow to include the firmware browser (previously called M5Burner). I update my firmware using these options/buttons (see screenshot, the arrow next to the firmware was moved from the top bar to be next to the firmware texts). I picked because that would be most stable.


    PS I used a downloaded IDE, not the online version

  • Thanks- this screenshot shows what I've been trying to do- when I click that download icon, nothing seems to happen- what happens for you? And then when I try to "Burn" it says you must download firmware before burning it.

  • A green bar was displayed while it downloaded:


    Next step was indeed pressing the burn button on the right side of m5burner. A log was shown with lines counting to 100% for two times. (I might have pressed that erase button first). After that it worked properly

  • Ok, thanks. So mine doesn't show up with the green bar. It also shows my device is "disconnected" even right after I try to connect, so maybe that is why it is unable to download.. but I don't know why it doesn't stay connected.. I know it is the right port, as it is the same one I used on Arduino

  • The green bar is just for downloading the firmware to your PC, the burn step is for getting the firmware from your PC to your device. Did you install that usb driver? I did read somewhere people were having difficulties with that part.

  • I have the Silicon Labs driver downloaded. I should also add I'm using the M5StickC- I see some posts that maybe it isn't compatible with the Desktop unless it's in USB mode, but my device doesn't go into USB mode because it doesn't have UI flow on it to begin with...

  • If you have been using arduino then UIFLow will have been deleted from the M5Stack or stick.
    M5 Burner must be placed in a folder called M5Burner to work (folder has to be created manually) one this is done then the download will start working.

  • @kgobes I suggest that you take a look at the Visuino IDE ( )The basic version is very reasonably priced(free trial period too) and there is a " PRO" version. The fact that is it not free provides support, you get an interlocutor , you are not given the run around and don't have to rely on forums so much. That's precious and saves a lot of frustration. Also this means that the software is continuously under development and they are prompt to react to issues. The developer makes money on the software, not the hardware modules. That makes a world of difference. Only my opinion anyway. Michael

  • @ajb2k3 I will try to find documentation on this and try it out... UI Flow though was not ever on my M5StickC- I also bought multiple kits and none had it on startup- they go right to the factory mode rotating through accelerometer/speaker, etc. Maybe I have a different version of the stick?

    @Pumpui Thanks! This is a good suggestion for an alternative; I think Visuino is block coding. However, I'm really interested just in using Micropython on the device in the easiest way possible, but that doesn't seem to really exist. That's why I wanted to see if UI flow could do micropython. (have tried Thonny which crashes my computer and others that I couldn't find clear documentation on connecting to serial port)

  • Ah, got it to work! thanks @ajb2k3 I didn't know there was a separate M5 burner tool. For anyone seeing this post in the future with same confusion, here is the doc to follow for downloading m5 burner and flashing your device, these two steps got my device to pull up an API key once it was done, so now I am able to use UI flow-

  • @kgobes Yes Visuino is block coding, I thought that what you were after wanting to use UiFlow. Of course the latter can display the dose as well. Cheers !