IDE crashes after startup and webIDE cannot connect to device (Upload code failed, maybe your device is offline check it and retry)

  • Hi Guys, I'm new to M5stack and I'd like to build some code to play a video from the device triggered by an I/O. Nice idea, but so far I'm getting kind of frustrated because the IDE I've downloaded crashes right before it shows the setup screen.!! I've tried to disable anti-virus/firewall, removed node-js (might interfear) but nothing seems to help. What to do? Anyone?

    Secondly I tried to use the webIDE. After entering the APIKEY, it complains the device is disconnected...0_1588339426306_M5disconnected.png

    I do see the COM in the PC's device manager, but its connected and there is no problem here. Also I've installed the drivers and upload software.

    After clicking the reloading button there is a message on the top right:
    Connecting M5
    Upload code failed, maybe your device is offline check it and retry

    How to get working on this lovely device???

  • I have exactly the same problem since weeks!
    Since Firmware 1.5.x it is not working.

  • Where you able to get it working with other firmware somehow?

  • Hi, i m new too on M5Stack... May I ask you if you installed Firmware with M5Burner ? If not you must do it. Chose 1.4 or 1.5 and fill the entry for your WIFI .
    Then just on the right of [Disconnected] you have a refresh button, try it , and again ..

  • @spoetnic
    Hi, I have tried it out with all previous versions of firmware.
    And I have to told you, that it does not work with any.
    Also I have tried to upload code to the device from "Microsoft Visual Studio Code", using the same usb driver.
    Result: It works from VS Code like a charm. So it must be a bug in UIFlow. UIFlow had problems with connection since beginning, but with the newest version I cant connect to the device or just for short.

  • @serge
    You can install new firmware directly from UIFlow. First click on menu "FirmwareBurner" then download the wanted firmware and then "Burn" it to the device.
    That is the only thing that works :-)

  • Hi, thanks for your reply. I was informed by someone else it is probably a windows problem and he advised me to install my windows again...
    Anyway, I will try to use VScode. Probably in here I can't use the UIFlow, only python? Thanks guys!

  • @spoetnic Dont waste your time to install windows fresh. This advise is stupid. I use windows since 1985 and I had never a problem that needs to install windows new ;-) It would be too bad, because if you are using windows as a professional, then it will take hours or days to setup it again with all programs and make all settings. As I have figured out it is simply a bug in UIFlow.
    Ps: Dont share you Api-Key.

  • I've downloaded M5burner for installing new firmware directly, but the .exe also won't run. I tried to disable all PC protection software, but no difference...

  • @spoetnic M5Burner needs to Be put in a folder called M5Burner before it will work.
    I wonder if that is the same problem With UIFlow crashing at startup.
    It may be a problem with windows but DO NOT reinstall windows.
    What driver is the com port trying to use as it could be a driver conflict?
    Also both windows and OSX need to be shut down and cold started after installing the drivers in order for the drivers to finish installation properly. If this cold start is skipped it can sometime result in a corrupt or conflicting com port driver install.
    And last thing is to try a good quality USBC lead as they are prone to failures.