BugC problems

  • I have tried both UIFlow and the demo Arduino program and both have problems. Starting with the UIFlow it is a simple program just to test that the motor controls work.0_1586147983050_Capture_Software.JPG In this program it justs loops through the functions: motor0, motor1, motor2 and motor3. At each function it is meant to pulse the motor for 5 secs and turns on and off RGB LED patterns on the two LEDs. The problem is that the program stalls on the first function and does not continue. Motor0 stays on. If I remove the motor control statements the loop completes and repeats and the various patterns of the RGB LEDs work. Could the motor control hardware be defective?

    I also tried the demo program: BugC.ino (from https://github.com/m5stack/M5StickC/tree/master/examples/Hat/BUGC but it will not compile. I am using Arduino 1.8.12 and have set the Arduino IDE to Stack5C and have all of the Stack5C libraries installed. The compile errors are:
    bugC.cpp:44:8: error: 'class M5StickC' has no member named 'I2C'

     M5.I2C.writeBytes(BUGC_ADDR, 0x10,  color_out, 4);

    Multiple libraries were found for "SPI.h"
    Used: C:\Users\phili\AppData\Local\Arduino15\packages\esp32\hardware\esp32\1.0.4\libraries\SPI
    Multiple libraries were found for "FS.h"
    Used: C:\Users\phili\AppData\Local\Arduino15\packages\esp32\hardware\esp32\1.0.4\libraries\FS
    Multiple libraries were found for "M5StickC.h"
    Used: C:\Users\phili\Documents\Arduino\libraries\M5StickC
    Multiple libraries were found for "Wire.h"
    Used: C:\Users\phili\AppData\Local\Arduino15\packages\esp32\hardware\esp32\1.0.4\libraries\Wire
    exit status 1
    'class AXP192' has no member named 'SetChargeCurrent'

    Is there a configuration problem with the BugC.ino or the libraries? The M5.I2C.writeBytes() function is not recognised.

  • @dsrc12 thank feedback. we will fix this UIFlow bug as soon as possible. about the BugC Arduino example compile problem . you could trought clone the laster version lib to solve it.

    github link:https://github.com/m5stack/M5StickC

    clone the library , then replace files to the Arduino lib path

  • Thanks for the reply. Got the Arduino library example to work. Looking forward to a UIFlow fix. See my review at: Another Uncontrollable Bug: BugC from M5Stack: https://www.facebook.com/thomas.andrews.357/media_set?set=a.2587374321367103&type=3