M5Stack Bala Battery?

  • The documentation on this M5Stack Balance car is terrible. I tried the quickstart directions (turn on M5Stack Fire then turn on base). The Fire powers up, but the base does not. There is supposed to be green LEDs lighting up on the bottom? I don't see anything written where you even have to charge the battery in the base! Do you charge it by itself? Do you charge it with the Fire on top of it? How do you know it's charging?

    I assume you can charge the battery in the base by itself. So I plugged it into a USB supply. There is a sold red LED light on the right. The left LED (I think that might be an LED) is off. Since the right LED is solid and not blinking, does that mean the battery is fully charged? Can you power the base by itself (without the Fire on top)? When I press the base power button, nothing happens. Can you power the base on while it is charging? I do feel the top of the base getting very warm as I have it plugged in.

  • @happy-hippo

    actually , you can connect the usb cable to the bottom , then put the Fire on it top site, then it will charge the bottom and Fire at the same time.

    the green leds lighting , that mean bottom working.

    if you have any question about the product , pls recording a video or photo to show me the question , then we will help you solve it. thanks

  • @m5stack I don't think it is working correctly. When I push the button on the base, as indicated by the arrow on the picture, nothing happens. When I have the base plugged into USB, the red light is steady on. The top of the base feels very warm.1_1573516836915_M5Stack-bala-charging.jpg 0_1573516836914_M5Stack-bala-backside.jpg

  • @happy-hippo did you has upload the program to the Fire?

  • @m5stack I thought the unit was preloaded with a program. When I turn on the Fire part, it looks like it is trying to start a program.


    I looks like it can't do anything because it is not receiving any data from the base unit. The base unit is not powering up (no green leds).


  • @happy-hippo didn't load this picture in the last post for some reason:


  • @happy-hippo you need turn on the bottom power when you put the Fire on the top site. if click the bottom power button ,the Green LED still not lighting , maybe should be charge it.

  • @Happy-Hippo in my experience the power button on the base had to be held in for quite a few seconds before it turned on, not sure if you've tried that already.

  • @lukasmaximus Thanks, but I tried that already. No Power. My original question is what does the solid red LED on the base mean when it is plugged in? Charging? Finished charging? Charging problem? When I charge the Fire by itself, it blinks while charging. I've had the base plugged in for many hours but the LED is solid red. I took apart the base to see if anything was disconnected. There is not anything obvious wrong. The battery is very sticky though. Is it supposed to be?

    How do I get a replacement? As this is not usable.

  • @happy-hippo when you connect the USB cable to the bottom, the green leds not lighting?

  • @m5stack No green lights are lighting no matter what I try.

  • @happy-hippo maybe the bottom it's broken. pls contact to the shop.

  • What is the shop? Where I purchased the unit?

  • @happy-hippo Where did you buy this Bala? just contact they。

  • I got it from Banggood. They are telling me I need pictures of the packaging, which I don't have anymore. So I will be really mad if I have to lose money on this.

  • @happy-hippo That's weird that they ask you for packaging pictures. Was it in a card board box? perhaps we can send you some pictures of the box if we have one lying around

  • @lukasmaximus

    1. Put both M5 Fire M5 Bala on top of each other. Now both batteries should be charged first.
      (If not, insert the USB plug into the M5 Bala and plug the M5 Fire briefly off and on again)
      "Now a green LED should light up on the left and right side of the two wheels of the M5 Bala. In addition, a red LED flashes on the M5 Bala to the left of the USB port, charging the battery of the M5 Bala. Now a red LED should also flash below the SD card slot on the M5 Fire. So the M5 Fire is also charging.

    2. if the M5 Fire LED lights up permanently and the LED on the M5 Bala next to the USB port is also lit up permanently, both batteries are charged, you can now remove the USB cable.

    Now remove the M5 Fire from the M5 Bala and place it on the M5 Fire on the floor where you want to ride.

    1. press the On button on the M5 Fire and simultaneously the C button on the M5 Fire, after the M5 Fire has started it will beep and she calibrate the gyro sensor.
      5 As soon as you can see the gyro sensor curve on the screen, plug the M5 Fire back onto the M5 Bala. And lo and behold it balances on the spot.

    greetings skink

  • @lukasmaximus said in M5Stack Bala Battery?:

    That's weird that they ask you for packaging pictures. Was it in a card board box? perhaps we can send you some pictures of the box if we have one lying around

    I know why you want the pictures of the cardboard box!
    I ordered my M5Bala from Aliexpress. On the back of the cardboard box there is a sticker with two numbers.
    One under SKU:_ _ _ _ _ and one under SN: _ _ _ _ _ _ I guess you need these numbers to complain to M5Stack !? That's my guess. Since these two numbers are stored in M5Stack and information about when they were manufactured and so on.

  • My balancing robot has an identical problem. But not from the beginning: At first it worked. But then the motor board failed. I can't tell if it's related to a connection via USB for loading the battery or if it just happened. But it is definitely the board that is broken.

    I have noticed that the case gets warm when I try to charge it. The red LED lights up continuously, indicating a fully charged battery, but the unit won't turn on. There are no green LEDs on the motors. As I said, it worked in the beginning.

    I have noticed that the IMU on the core unit no longer provides data when the motor unit is connected. It looks as if the I2C bus is blocked.

    If a USB cable is connected for charging, the IC 5306 gets hot above 90°C:

    Board Top side
    Board Rear side
    Temperature of IC 5360
    Temperature at the rear side

    By the way: Now, the red LED is no longer lit at all!

    I think the board is broken. I measured the voltage of the battery when the battery is connected to the board but it shows 0V. Maybe the short circuit protection shuts down? Good to know, otherwise my flat would be on fire now....

    The battery is working fine inside another M5Stack Core unit, so the battery is not broken.

    I measured the Current consumption of the board without a connected battery:
    Current consumption

    Again, a further indication that the board is damaged.

    Looks like I will need a new board...

    Does anyone else have a problem with the board?

  • @hague Sorry, the reply was late. pls contact our store , we will be help you.