SIM800L really works?

  • Hi, I have a module SIM800L for the M5stack. Does anyone use the SIM800L module? Sometimes it works, sometimes not. If I send a simple command like AT or something similar, no problem. But if I use an HTTP request or an other complex operation, sometimes it works and sometimes not. I obtain different errors from the module, but usually the errors are generic and not useful to understand where is the problem. If I use the same source code in a different module, for example a SIM808 or with an external SIM800L the code works well, when I use the SIM800L module with the M5stack I have the problems. Do you have some example of usage in a real environment, not sending simple SMS but something with GET or POST requests? I use a 5V 3A power supply (the official Raspberry PI 4 power supply) so I think I have enough current for the module. But I used also a 5V 2.4A mobile power supply with the same problems.
    I now ordered a new SIM800L module, maybe my module doesn't work well. I don't know what to think. Any suggestions or tips?

  • @robottini That would interest me, too.
    Is it also possible in Germany with a normal data sim card? Who has such a thing successfully on the run and can show example codes.
    I use MicroPython.

  • I personally haven't been able to get it working in the UK, but I think that's simply because it's too complex for me to understand/debug. @Dimi our Russian colleague made some nice guide for us in Uiflow and Micropython showing how to use it
    and another guide here

  • Hey Guys,

    so i had 2 SIM800L modules here for project
    On my modules VCC was connected to 5VDC line passing through a single Shottky diode.
    According to Wikipedia:
    Schottky diodes' voltage drop at forward biases of around 1 mA is in the range of 0.15 V to 0.46 V
    So the resulting voltage on the Vcc pin in my case was 4.7V
    This is out off spec for these modules.... Normally it should be between 3.4V and 4.4V

    I then replaced the shottky with a normal diode but that didn't fix it completely either,
    I think the 5V power source can be a bit flakey in supplying current to this module. (can consume up to 2A)

    What worked for me is :
    i removed the diode and connected the Lipo battery to the Vcc of the module intead.
    Now it gets a Vcc or around 4V and the battery can supply enough current to overcome the high demands. (if it is charges at least a bit, so you could have troubel in the beginning of power on)

    i've had mixed with results with different options for the Vcc, but this one worked the most stable to me
    Maybe this could help in getting it to work.


  • Hi,

    I have myself struggled to get the M5Stack SIM800L module working with the M5Cores and the M5 Battery packs.
    My issue was caused by an over voltage power down occurring erratically.
    I have been able to bypass the powerdown by passing "AT+CBATCHK=0".

    So far it seems to resolve my issue.