M5 stick C wont turn on am i missing something?

  • Hi everyone hope you can help if I'm missing somthing., I bought a M5 stack C.. and I can't seem to get it to turn on. I've plugged the usb-c cable into a known good USB source and I get no charge indicator lights nothing. I've left it plugged in for a few hr and still nothing. I hold the power button for varying times from quick press to 6s to 15s and nothing happens I've tried all button and combination. i think i just have a bad one unless there is a trick i don't know. I've also tried a dedicated USB C charger from my phone and still nothing.... no light life or smoke just dead.. did i get a bad one? and if so how to get it replaced i tried the contact page and when I submit it just errors out. Any help would be great i really wanted to try uiflow

  • If contact is not working you can try through facebook, instagram and email.

    Try sales@m5stack.com.

  • Hi

    It did happened to me few times on new Sticks, it looks like the issue sometimes is the testing runtime used before shipping.
    Try this:
    If it doesn’t turn on connect it to your computer,
    launch the uiflow firmware utility,
    you should see the serial port listed (the serial port chip is independent from power supply and should work),
    erase content,
    burn with fresh firmware
    Repeat if necessary and make sure battery is charged

  • Apparently it is a common issue with the battery protection circuit (I have experienced this now!)

  • M5Stack

    @cncninja sorry to hear your having issues with the stickC. As @iPodLux said, try reflashing it. First though if it doesn't show up in device manager on windows or system report on Mac then you probably have a dud and we should be able to replace it for you

  • if some firmware in stickc, please connect g0 to 3.3V, next insert usbC,it will work well

  • @heybin said in M5 stick C wont turn on am i missing something?:

    if some firmware in stickc, please connect g0 to 3.3V, next insert usbC,it will work well

    Though this does work, I'm curious to know if you are working on a real fix via a firmware update.

  • sorry, this is caused by the battery voltage being too low(not booting for a long time). there is no way to solve it through the program,

  • So i have a dead on arivel M5stick C and my m5 fire does not support the usb modual i bought to add usable I/O.... not really loving this..

  • I just wanted to mention if you charge the m5stickc using a usb psu such as what you use to charge your phone it seems to charge the stickc battery and it turns on if you give it a few minutes. Not sure if this might be attributed to the usb output voltage on my computer not being stable but this always works for me. On the usb psu the voltage was 5.01v and on the laptop it was 5.22v so perhaps the overvoltage is an issue. I have 3 or 4 stickc devices and on a couple of them I always have to charge them first before they will boot.