USB Device not recognised



  • @ajb2k3 I have put a 2.2uf capacitor between RST and gnd as thats what I saw in the forums, I don't have another USB adapter unfortunately.
    Is it the USB that is causing the issue?



  • From what I understand, it is the driver for the inbuilt adapter that causes problems.



  • @ajb2k3 Yeah, the strange thing is that I have another device which seems to use the same driver as they had the same name in device manager, and the other device seems to work fine.



  • I have tried it on multiple computers and they are all coming up in device manager with "Windows has stopped this device because it has reported problems. (Code 43)



  • I have just tried taking the bottom section off (the section with the battery in it) and it seems to be working fine now, as soon as I put that bottom section back on it doesn't work again, so strange....



  • @kieran-osborneUSB Device not recognised 中说:

    I have just tried taking the bottom section off (the section with the battery in it) and it seems to be working fine now, as soon as I put that bottom section back on it doesn't work again, so strange....

    Interesting, I never made that connection before.



  • Having the same issue again!!
    I'm using a USB Device Viewer and it says:

    *!*ERROR: No open pipes!

    ===>Device Descriptor<===
    *!*ERROR: bLength of 0 incorrect, should be 18
    bLength: 0x00
    bDescriptorType: 0x00
    bcdUSB: 0x0000
    bDeviceClass: 0x00
    *!*ERROR: Device enumeration failure



  • Wow! haha, just found the most weirdest solution,
    not sure if the USB port in the M5 stack is wired properly,
    If I turn the USB C cable around then it works, so it seems like the cable has to be a certain direction for it to work, I have even tested this with multiple cables all with the same result!, so if it's not working try rotating your cable!



  • @kieran-osborneUSB Device not recognised 中说:

    Wow! haha, just found the most weirdest solution,
    not sure if the USB port in the M5 stack is wired properly,
    If I turn the USB C cable around then it works, so it seems like the cable has to be a certain direction for it to work, I have even tested this with multiple cables all with the same result!, so if it's not working try rotating your cable!

    this doesnt always work for me and i tried another cabel



  • I had the same bizarre issue and I found the solution here ! Just turn the USB C plug around and it works ! Weird.


登录后回复
 

与 M5Stack Community 的连接断开,我们正在尝试重连,请耐心等待