Core2 V1.1 Battery not working if unplugged

  • I have the Core2 original and now the v1.1. But the new unit is not working
    when unplugged.

    Are there any special v1.1 calls to get the battery to work? Just like the
    vibration needing a new call in v1.1, is there something special?

    The battery voltage is working (which I've used for battery percentage).

        batVoltage = M5.Axp.GetBatVoltage();
        batPercentage = (batVoltage < 3.2) ? 0 : ( batVoltage - 3.2 ) * 100;

    I've tried the following to no avail.


    Is it possible the battery isn't working? It's plugged in (after opening the unit).

  • No, you just plug it into a working USB port and leave it for a few hours.
    If that doesn't work, remove the base and check the battery pins for a 3.4V with a multimeter. Also check to see if the battery is starting to inflate.

  • I had a similar issue after a bad flash. I had to pull the battery to get it to boot and enable a clean flash. After re-connecting the battery it would not boot on battery only. I assumed the battery was dead. I plugged it in to charge for 5 mins, then unplugged, then replugged for 5 mins, I did this 2 or 3 times, then left it to charge for 30mins. It's now fully alive. My understanding is sometimes the batteries get slightly over discharged and won't charge, plugging in and out gives it a little boost to wake it and start charging. This is from my experience with other battery devices.

  • That's very enlightening. I've since got the battery to work but it seems to be working along the lines you mention. I actually exchanged batteries with Core 1 and it worked perfectly. But the Core 2 has some issues.

    When the battery is dead, plugging in won't bring ut alive until maybe 20 minutes.

    So I don't think it's totally the battery but rather how it connects and Core 2 management of the power.


  • Unfortunately as of today, my Battery isn't working again. I can update and run will using USB power but unplugging kills the M5Core.