Cardputer COM Not Working

  • You have tried holding the go button in and plugging in the usb cable?

    The good thing about the cardputer is that it runs stock M5StampS3 so you can just very carefully replace the stamp.

    Only buy direct From M5Stack or a reputable seller like Adafruit

  • Hello guys

    pressing and holding BtnG0 and plugging in USB only puts the M5StampS3 into download mode if the battery power switch is in OFF position.

    With a charged battery and the battery power switch in ON position you'll need to hold BtnG0 and the press BtnRst to get M5StampS3 into download mode.

    The reason is that for the M5StampS3 getting into download mode it needs to (re-)start while BtnG0 is held.


  • @robski No problem, thank you for the help so far. Tried with the S3 disconnected, but no results.

    @ajb2k3 Yes, tried that too. The closer to download mode I get is the Cardputer not autostarting when plugged. Maybe I'll need to get another. :(

    @felmue Thanks for the comment, felmue! Already tried both ways. As commented above, if I start with the BtnGO pressed, the cardputer does no autostart, wich is progress. However, it doesnt start on download mode too. Both options and it still isnt recognized on the pc/notebook.

    Just bought a multimeter, will start to look for damaged components on the board and the S3 pins. :/

  • Have you tried a new data sync usb cable?

  • @ajb2k3 Yes, tried 3 cables on different USB ports, with and without the USB hub I've mentioned.

  • Well, the only think I can think of is to order a replacement stamp and swap it to see if the stamp has gone faulty.

    Open M5Burner,
    Try taking the plastic cover of the stamp to reveal a button, power on press and hold that button while pressing reset, DO NOT release the button until 5seconds have passed after releasing reset. A blue box should appear in M5Burner giving a new port number

  • @ajb2k3 Yup, tried that button too xD
    I'll with the multimeter if I can spot something wrong. If not, I will save some money for another Cardputer or something similar in the end of the year. I'm pretty sure that if I try to replace just the S3, I will mess with it. :(

  • @hanktttop The screen is soldered direct to the StampS3 so you will need to be careful of that when replacing the stamp.

  • @hanktttop

    Guys, I found out how to make it on mac, where i had same problem. Cardputer off, connect usb cable to it, hold btngo and press btnrst - screen will go dark, release fingers, your in m5loader you'll see popup that its connected.

  • @doko178 Thanks for the comment, doko.

    Still nothing even on the device manager. Now I believe I have tried every single button-press combination possible :D

  • @hanktttop What about pressing btngo when connecting usb? Works for me. I hope you'll solve it!

  • @doko178 Tried that some days ago. At least it prevents the cardputer autostart, but nothing about download mode. Thanks for the help xD

  • I posted a guide in the FAQ's

  • @ajb2k3 Thanks, still nothing.

    Thank you very much to everyone who commented and helped, but I think I'll stop here. It took so many tries that some of the S3 pins are starting to bend, even though I'm careful when removing/inserting the chip.

    I think I could end up damaging the cardputer if I continue with this stress on the components. I must continue my studies with simpler devices like the Portapack Mayhem until further notice.

    Thank you very much for your comments, it is a very receptive community.

  • You can get the StampS3 separately (the core of the Cardputer) and experiment on that.

  • @hanktttop I have the same problem, my cardputer arrived yesterday, a follow all sugestions on this post.

    Then I ask on discord channel hackingtroop about the problem, and their sugesto to try another cable, It's works. But one point of attention, the LED don't work as expected, anyway the cardputer enter on download mode.

    Hold BtnGO, plug in o cable, and burn firmware. With the new cable, just plug and MM5Burner show pop-up about device found.

  • @has-oliveira who are you on the cardputer discord

  • @has-oliveira Tried multiple cables, no one worked. Did you used any specific brand?

  • @hanktttop have you used the firmware flashing method I posted in the forum?

  • @ajb2k3 Yup, I think this thread have (almost) all the possible methods of flashing the cardputer. Tried all posted here, the one on the FAQ, some I saw on other threads and Reddit (all very similar, just changing the order of pressing the buttons), some suggested on Github, etc. :(