Powering M5 Stack Core 2 with Base 26

  • Hi, I have a Base 26 connected to an m5 stack core 2 and would like to power the Core 2 by using the integrated barrel connector on the Base26. It does not seem to work without a battery and I was tring to minimize the amount of cords by not plugging in the usbc. Is this possible?

  • Hello @Variance

    M5Core2 library automatically switches to use the 5 V input from the M-Bus, but I think only if there is no USB plugged in when it is booted (and probably no battery as well).

    Try without battery and no USB plugged in and then provide power through the integrated barrel connector.


  • @variance, I have a similar behaviour with Core2 on the IoT CatM base. Without battery installed the DC doesn't switch on the Core2, needs a connection via USB-C to trigger power up. But once started it is fine to remove the USB-C - it remains powered by DC. Is this what you experience or are you saying it just doesn't power up at all on DC?

  • Hello @gavin67890

    are you saying you have DC plus battery installed and need USB-C to trigger power on? If yes, how do you know it actually runs from DC and not from battery?

    Maybe there is a contact issue between base and M5Core2?

    Have you tried only with DC, no battery and no USB-C, but push the power button to turn M5Core2 on?

    BTW: I have an M5Core2 which I power from an external 5 V source through the 5 V pin on the M-Bus (no battery, no USB-C) and it power on just fine when 5 V are applied.


  • Hi @felmue,

    • DC with Battery installed Core2 starts when DC is plugged in.
    • DC no Battery installed Core2 doesn't start when DC is plugged in.

    Unfortunately my power button is broken, so I have to start by plugging in the USB-C. I can confirm that is stays powered by DC when removed (no USB-C, no Battery).

    I also have another Core2 on the GoPlus2 base, same with the battery installed it starts from DC directly, no USB-C. @Variance, if needed I could at a push disassemble my Core2 on GoPlus2 base and take the battery out to compare operation. One tip, make sure the Core2 and Base are tightly pressed together, ideally with M3 screws because the pins don't always fully engage.

  • @gavin67890

    I have the same problem. Trying to find a solution for the powering up from battery connect for my Geige Counter project https://bgeigiezen.safecast.jp). Originally I build the board for M5Stack Core1 gray and all worked fine. However, for M5stack Core Black, it did not power up from DC. Then I could not get Core1 anymore and started to use Core 2 V1.0 and that powered up nicely on battery connect. But Core 2 V1.1 does not do that, anymore. Still trying to find ways without adding extra components like a delay cap/resistor on the Enable pin to get it started.

    Please check if you have a Core V1.0 (axp192 PMU) or a Core 2 version 1.1 (axp2101 PMU) For me a Core 2 V1.0 powers up from DC connect. But Core2 V1.1 does not.

    Rob Oudendijk