Can't Run the Config util

  • Getting UIFlow to run on M5StickCPlus V1.1
    I've only had these two sticks for a day and was able to get several demos to load and run properly under Arduino IDE 2.1.0 and using the your Burner utility here on this site.

    However, to get the UIFlow to work I understand I need to get the device specific API key using the Configure utility. The utility seems to load Ok but when I ask for my configuration, it always fails. Is this UIFlow for M5StickCPlus incompatible with my M5StickCPlus V1.1 device? What could I be doing wrong..

    BTW when I tried to UNINSTALL it, the GUI said it was successfully uninstalled but I could not power the device ON, or see anything but a Black screen.. fortunately I was able to re-program it with a Volos Projects Watch demo again using the IDE 2.1.0 and that app is still working.

  • have you wiped the stickcplus and installed uiflow?
    the apicode is only for uiflow access.

  • Thanks very much for your reply,.

    Yes I was ONLY trying to install UIFLOW... sounds like the StickCPlusV1.1 units I have should be compatible (tho you haven't answered that part of my question)... but in reply to yours, Yes I think so .. at that time I was going thru loading and testing several other demos found on that part of the M5StickCPlus site, and each asks if you want to "Remove" each app, so I was doing that ..

    I did not however see an app that was titled " Wipe" so I cant say with 100% certainty that I did a Wipe.. what I did do was follow the Installation guide .pdf for the M5StickCPlus and I believe the utility was called the Burner Utility was what I was using to load these other demos.. Not all would work but most did.. Independent of this M5 Site I have also been using the Arduino 2.1.0 IDE to load and run a few Velos Projects successfully on the two sticks I have never done a "Wipe" before re-uploading the code, yet they run fine.. Could you share a link to the Wipe code you are suggesting is a pre-requisite step BEFORE installing the CONFIGURATION utility that is needed to get the api code to allow UNIFLOW access? ... Tho I'm not drunk yet, I will grab a couple bottles before I try again cause UNIFLOW may be easy .. but getting an API code needed to install it apparently isn't. :)

  • There is no wipe code.
    When you open M5Burner, select the stickCplus in the menu on the left, download uiflow and you should then see a red button called "Erase" which runs the esp tool erase function in the background.
    You should always use the "Erase" before installing new firmware from within M5Burner.

  • Ok the s/w isn't intuitive, or forgiving at all BUT I am making some progress, and was able to initialy download and install a PRIOR version of M5Burner, and then delete that and get the latest UIFLOW web enabled version and then when that hung, the Desktop version of UIFLOW and set up a Blocky app and clicked to Run a simple LED project ( per the tutorial) in the device BUT at that point the device hung and I couldn't get past an error saying the I/O port was disconnected. I tried the StickCPlus switches 1'st, then cycled Power OFF/ON on it, then disconnected and re-connected on the USB cable and nothing seems to get past the Port disconnected error.. So I must ask is there an easy fix for this case where in this UIFlow Programming Mode the device wont talk to and receive new code from the port?

    I do hear the Win11 USB Port disconnect and re-connect tones as I disconnect and reconnect the device but UIFLOW wont allow another download regardless of what I do with the disconnect/reconnect icons in the lower bottom left of the GUI etc..

    what causes this thing to hang up the USB port so easily? and how to I recover ? Thanks jimS

  • Don't use the Desktop version, only use the online version as the desktop version hasn't been updated in a while.

    The Port "hang Up" is caused by a conflict between windows and the internal driver (you need to install a dedicated driver from the M5Stack site) The issue is that when the port crashes, windows is not releasing the port.

  • Ok Well I do believe you and assume that you are correct but must ask..

    when I install your site's recommended driver.. what will be the impact on the half dozen other dev kits I'm using that all have no issue with the driver that is installed now?

  • Great question. The driver is provided by the USB chip maker, not M5Stack and so should not be a problem.
    That said, you now mention other kits so have no idea what drivers they use to communicate.

  • some USB to UART chips such as the CP210x family are customizable by the device manufacturer to have its VID and / or PID.
    In this case you need also a cusomizated driver or telling the existing driver the new VID/PID (which is possible for example in a linux environment). It is no problem to have several drivers in parallel as they only work for devices with the correct VID/PID.

  • @ajb2k3
    Since you did not mention what specific driver is needed for M5StickCPlus v1.1 I went back thru the docs in this site on this CPlus module and went thru the install sequence docs. I also found and ran your utility that re-installs the factory firmware and did that successfully .. so the module should be back in its initial state. Then went on and since it mentions an FDDI driver ( and of course there are two types of USB driver chips the 2104 and the 9043 sp? ) but I got the date and rev no on each then went to your link to download the driver needed by these M5StickCPlus devices and downloaded and unzipped it and then went into my Win11Pro Device manager and with the device plugged in I attempted to install that newly unzipped driver file and Windows Device manager says "the Best driver is already installed" So, at this point after comparing the actual .dll file name and date with the limited info on you site, I do believe I already had the most current and most applicable driver pre-installed on my PC.. that FTDI driver is dated 7/5/2021 Ver and it's what I've been using for a few months with this and other dev module types. Its also what I have no problems using to install projects with the Arduino IDE 2.1 into the M5StickCPlus 1.1 with no problem.

    My only problem is your module hangs up in a made that won't allow me to install /run any of the various UIFLOW demos.. So I give up, I've spent enough time on this and will set it aside pending a specific answer on why I cant do that.. I believe It has NOTHING to do with my USB driver.. which appears to be the exact one recommended by the docs on your site.

  • @holofloh
    Thanks very much for this info.. Yes I agree, my Windows 11Pro has no facility to set a VID or PIN in the FTDI driver settings but it does at least appear to be the correct / identical driver as is recommended by the docs on this site that I am now, and have been using for this M5StickCPlus V1.1 device..