help needed to get started.

  • Why is it looking in the pictures folder?
    M5Burner should be in the root user folder or the programs folder!

  • Because it put the downloaded zipfile in here and extracted here...

  • As it is not a msi installer but just an exe i had never a problem running an exe not from the program files folder. Also from the temp folder.
    It is not playing a role sofar. This would be for me the first time.... if this is mandatory one must write a step by step standard procedure as idiot proof as possible...
    Nevertheless i an sure trying to extract into the program file folder will not solve the missing patch honest opinion.

  • Hi adam, I saw your review of cores3, sad that this part is not as straight foreward as one can expect.if i reckon correctly you struggled to get uiflow burned to the device as well. I did not get gow you did it!
    But you erase first the mwmory using m5 burner.

    The boot load mode was quite tricky to trigger.seems like
    On the atom s3 i need to press the side button for 3 seconds and a green led is shining for 2 secs i however do not know if you started thw mode. It stays in this mode untill you power off.

  • @dr_froggy_rd

    No it doesn't start in this mode. Thank you for watching the video.

    The second time it work fine.
    Connect to computer,
    Press and hold boot button for a few minuets and "Port ***** detected" will show,
    Click erase and wait,
    click write and wait,
    power down and rest the S3 device and UIFlow starts.

  • Hi Adam, so: I unzip my file in programm subfolder.
    open M5nurner .exe as administrator.I can update firmware list.... but still looking for the same patch in the unzipped folder: I have anotherjavascript error message:: It is not EPERM but ENOENT..
    However I connected the s3 to it. and push the left side button until green led flashes....then connect com6 (the detected port com there it is green) It fails to erase or to burn. failed to get mac. also when reducing the baud rate to 11000..
    I tried even the easyloader software without success...

  • I refer to ENOENT as Error no Entity, it means something is missing probably in you background tools.It's possible you need ESPIDF or ESPTool installed but I can't remember

  • Ok thks adam.

    By the way i have a m5stick cplus. I could burn uiflow on it.
    Does it mean then i can install any program made with uiflow on it?without needing to install the program via m5burner?from uiflow.
    I am looking for the key of each part cannot find those i have the sn feom the label ...
    By the way i printed the part yesterday and i neede to scale it a bit to fit the tailbat and a m5atom s3. Thank you for that you saved me time also i had to print it 3 times before getting the right dimensions.
    It may be due to my printer tolerances! I will send you the dimension i used. Bye


  • I have two stickv card what are those for.

  • @dr_froggy_rd You install UIFlow for the stickCplus to the StickCplus and the API key will be shown on the screen.

  • 0_1685651509434_apikey.png
    thx Adam....As you said I found it..

    I still do not know why it is not workimg with atom s3

  • For the S3 Generation you need to hold down a button for several second to get it into boot mode, M5Burner will report a new port detected and then you can try accessing the settings.

  • 0_1685740898653_error screenshot.png
    what the fuck esptool is not good. somehow

  • It is not working with two Tom s3 i own to burn a firmware on it...
    So as it seems to be working on another iot dev kit, i will rather advice going for the stick c..
    Bsst Regards
    Frog Frog

  • @dr_froggy_rd
    Have you held the boot button down until the green boot led lights up?

  • Hi there so thanks to ajb2k3 I was able to burn the atoms3. the issue was a software one.
    which has been resolved so far by latest m5 burner update. Once I could log in onto my account from the software.
    Now I can even start to play with background colour as well but uiflow2 atom s3 misses a lot of subpart: i cannot get hardware imu to get pop up. however those are present on uiflow but I cannot run from uiflow.
    I see a remote m5 function which seems to be an interface for a smartphone.
    which can act as datalogger.. what I was intended to do...
    this is awesome.I f I can do that so easily but this is not as straight forward. the option do not appear on uiflow 2...0.17

  • please see your other post and check out my YouTube video on the AtomS3

  • @dr_froggy_rd
    "Uiflow redirect me tothe shop."

    Oh man, that loop of trying to figure that step out, and being redirected to the shop over and over was extremely frustrating. It was not a smooth customer experience.

  • @mtylerjr said in help needed to get started.:

    "Uiflow redirect me tothe shop."

    Oh man, that loop of trying to figure that step out, and being redirected to the shop over and over was extremely frustrating. It was not a smooth customer experience.

    I am not sure I understand what you mean here?

  • @ajb2k3 When I was originally trying to use UIFlow2, I wanted to select my device (a CoreS3 I had just received). I wasnt aware yet that I had to go through other steps first, to make the device appear in the "Select Device" popup window of UIFlow2.

    So, just trying to connect from UIFlow2 without knowing any better, I tried to select my device, but the only options in that "Select Device" window, under "My Device", were "Private" "Token Required" and "Public" with no explanation of what these meant. It was 100% not clear or intuitive to me what the purpose of these three options were.

    The clickable buttons next to each of these - the only UI options available to try - all just redirected to the store page. Since I already bought and owned a device, this was very very frustrating. I had no idea what the intent of that screen was - all I knew is it really wanted to send me to the store, and that I had nothing else to try. I had no idea of the need for m5burner for example.

    It was only much later when I figured out through trial and error how to get my device bound to my account, and the UIFlow2 image burned, before it would show up on that selection screen.

    There needs to be (in my opinion) a much higher level overview of the steps needed to get through your first connection to a device - something that would explain what that screen was, and when it was used.

    There may -be- something like that existing already - but I couldnt find anything.

    The "Documents" link at the bottom of the CoreS3 store page ( just directed to the page explaining pinouts, and modules, and the EasyLoader patch tool. (

    Critically, there is nothing on that last page that talks about the need for m5burner, or the steps required to connect to UIFlow2 - at least none that are obvious. There is a small menu at the bottom of the page, "developer tools" that goes to a page that lists links for many things including m5burner. But even then it isnt clear you need it, or what it is for - at least that is how it was for me.

    So It took a lot of hunting around, googling, dozens of redirects to the store, before I finally pieced together enough of an idea of the order of things to do.

    Someone else might have found all the info right away, I guess, and I was just not smart enough - but Ive been developing embedded firmware for over 40 years, on hundreds of platforms, and found the whole information-hunting process very frustrating for this product.

    Having said that, once I connected to my CoreS3, I was so happy I ordered several more products from M5Stack - Atom Echo Smart Speaker, M5StampS3, AtomS3 Lite, AtomS3, M5StickC PLUS, two Atom TailBats, Env-III module, CardKB Mini Keyboard, and some other battery modules, which just arrived, that I can play with this weekend :D