M5StickC Plus not recognized by PC

  • I have several M5StickC Plus units. Using the same computer, USB port and USB cable most of them will connect and work fine with the Arduino IDE while one won't. It does power on (the display comes on) but no COM port appears in Windows 11. Nothing shows or changes in device manager if I plug it in / out.

    I have also tried using a different USB port, different cable and a different PC with the same result. And anyway my main PC works perfectly with the other M5StickC units.

    This is the second unit that has failed in the exact same way. Both worked for a couple of weeks before failing. I threw the first one away thinking it must be faulty. All are relatively new (it's only been a few weeks since I received them).

    Any ideas how to get it working again? Or is it just a hardware failure (that has happened twice on two different units)?

  • @human101010 with the power on, click the power button and it will rest and start the sketch over.

    There is a more complicated procedure somewhere on the internet which I cannot find rn, on mobile!

    Did it ever connect? M5 did have supply different USB chips, you may need the CH340 patch.