M5Stamp Pico API key too short

  • The docs suggest that the WiFi AP name doubles as your API key. But it's only 8 characters, UIFlow wants 12 characters:


    I don't have the little USB adapter so was hoping to just fiddle around in UIflow to get started. Anyone know the secret to finding the API key on these? Did something change about the way it is configured?

  • I also noticed every other device in UIFlow uses an 8 character API Key (MAC). The m5stamp is the only one that requires 12. Could this be a bug or unfinished configuration in the app?

    As a last resort I tried the actual real MAC address of the device that I got from my router. That failed too, although I can see the device is definitely on the local network.

  • The 12 digit api code was on a label stuck to the front of the stamp Pico. If you have reset or updated you need to go into M5Burner and load the configuration data from the stamp to get the new API code

  • @ajb2k3

    I hooked up a FTDI adapter and am seeing these errors in the serial output. Did I get a bad board?

    14:41:58.735 -> Start factory test
    14:41:58.735 -> Start IO TEST
    14:41:59.066 -> 18 >>>> 1
    14:41:59.111 -> error HIGH-->>>OUT:26  IN:18
    14:41:59.738 -> 18 >>>> 0
    14:41:59.770 -> 21 >>>> 0
    14:41:59.815 -> error HIGH-->>>OUT:19  IN:21
    14:42:00.434 -> 18 >>>> 0
    14:42:00.473 -> 21 >>>> 0

  • When I boot in UIFlow mode this is how the serial output looks. But M5burner and esptool won't work at all...


  • Hello @greenleaf

    from the M5Stamp Pico documentation, section Program Download.

    STAMP-PICO adopts the most streamlined circuit design, so it does not include the program download circuit, users can download the program through the USB-TTL burner.

    If you don't have the USB-TTL burner board, in order to use M5Burner or esptool, you'll need to put the M5Stamp Pico into download mode manually by connecting a wire from GPIO0 to GND before powering it up. (For regular boot, the wire needs to be removed again.)


  • @felmue you are a god. I didn't want to order a $15 burning tool for my $5 m5stamp so I've been using a cheapo FTDI adapter. Connecting GPIO0 to GND worked like a charm.

  • Hello @greenleaf

    glad to hear it worked.


  • For future viewers of this thread, the API key is the same as the MAC address. You can usually find this on your router config where it shows device info. The MAC is also shown in the serial output when you connect a burner device (or FTDI cable as mentioned above.

    My problem was the device was stuck and needed reflashing. Once I did that it worked perfectly using the 12-digit MAC as the API key.

    You may safely ignore the 8 digit "API Key" that is shown in M5burner or the command line, this was a red herring.