M5StickC Plus arduino 8Servos HAT v1.1 example missing in repository



  • Hi.

    When I follow the link for the arduino examples in the 8Servos Hat documentation pages I get an 404 error.
    I.e. the links found on this page:
    https://docs.m5stack.com/en/hat/hat_8servos_1.1

    And in deed, they seems to be missing from the repository.

    But in another local project (platform io), I can see that the folders exists in the .pio example section.
    However there (in the 8SERVO_V1.1 example), it tries to include a HAT_8SERVO.h file, which seems to be missing from the example folder.

    Is there a better location I should go to, to find this example?
    Or has this file simply just been forgotten in a commit?
    (Or am I simply missing a include library or somthing?)

    I hope you can help getting me past this issue.



  • Hello @KjaerN

    the 8Servos HAT examples seem to be here. The M5StickCPlus ino file is here. And the file you mentioned is here.

    Thanks
    Felix



  • Hi Felix.

    Thaks for your repply, and sorry for my late resonse.
    I had some issues logging in again after I created my account.

    Your links got the example code to at least build.
    But once uploaded to the board I never get past "Connect Error" in the setup.

    I have two hats, and two M5StickCPlus, and same issue on both.
    So guess I still have some troubleshuting to do.



  • @kjaern did you ever get the 8Servos HAT v1.1 working? I just purchased one and was able to compile the code, but also never get past "Connect Error". I've also tried this with 2 different hats.

    Regards,

    Jay



  • Hello guys

    in this file M5Hat-8Servos/src/Hat_8Servos.cpp try replacing this line

     _wire->begin(_sda, _scl);
    

    with

     _wire->begin((int)_sda, (int)_scl);
    

    Thanks
    Felix



  • @felmue, It worked!!! Thanks! If I had a way to use this device to pour you a beer over the cloud, I would do so.

    Regards,

    Jay



  • Hello @makingwaves

    cool, thanks for reporting back.

    @m5stack: Please check out this pull-request. Thank you.

    Thanks
    Felix