Stamp Pico won't connect to UIFlow

  • I reset the unit, went to the captive portal, set my SSID and password and it connects successfully to my network. I can see that it is transmitting data on my router control panel. The light is pulsing green.

    But when I try to connect in it fails. I have carefully checked the MAC address, verified it on my router, and made sure I typed it in correctly. I've also tried resetting the device, reloading UIflow but nothing seems to help.

    What's the trick to getting one of these m5stack esp32 pico devices to connect to UIFlow?

  • @greenleaf it may have just been bad luck that the server was inaccessible .

  • Hello @greenleaf

    also make sure you have only one tab / window in your browser open with running.


  • also only use the latest updated google chrome.

  • Ok so the green pulsing light means "Normal, connected, ready for UIFlow"?

  • I think I probably have a defective unit. I have tried with only a single tab open, latest version of Google Chrome, tried it incognito mode also just to be sure some extension wasn't getting in the way. Despite all efforts it never connects to UIFlow. I know it's on the network because my router is showing it connected and sending/receiving some packets.

    I will probably stick with devices that have USB-C on them, this is way too much hassle and I don't want to have to rig up a programmer just to toy around with a prototyping device. Oh well, at least I'm only out $5.