M5Stack Core 2 appears to be bricked

  • No response ( no display or sound) upon plugging in usb power. Was working fine until I tried uploading a sketch. Burn fails. I am getting a response to ls:

    ls /dev/tty.wch*

    File "/Applications/M5Burner.app/Contents/Resources/packages/tools/serial/serialposix.py", line 268, in open
    raise SerialException(msg.errno, "could not open port {}: {}".format(self._port, msg))
    serial.serialutil.SerialException: [Errno 16] could not open port /dev/tty.wchusbserial537E0144481: [Errno 16] Resource busy: '/dev/tty.wchusbserial537E0144481'

    Any suggestions?

  • You probably uploaded a sketch which is blocking the port.
    Try using M5Burner to wipe the Core2

  • @ajb2k3 thanks but when you say “wipe” using Burner which operation are you talking about? In my post I show the output from an attempt to use M5Burner. I agree with your theory that The unit is running my sketch which is either holding up the serial connection or doing something similar. What I don’t understand about this unit is the apparent lack of a factory reset using the buttons somehow and starting from scratch with a boot strap or something similar. Is there no such function?

  • @david-bethesda no, there is no button press to factory reset.

    if you download and install m5burner which is an application used to flash firmwares to the core2.

    In the top right corner of the application in an "erase" button (you may need to resize the window) you can use this to remove any code running in the core2's memory.

  • @ajb2k3 Thanks. I referenced my attempt with Burner in the original post. I tried a subsequent time and it finally worked. So I think I'm good now. It's not clear to me how Burner could ever work if a program is attached to the serial port -- does Burner not require the serial port itself?

  • @david-bethesda programs can randomly block the port using m5burner sometimes resets the port (or something else strange ) and allows the boot loader to be over written resetting the device.

  • I was finally able to Erase and get things back to normal.